Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

In a Wordpress 3.5.1 network, I have six plugins which have updates available:

  • AddThis Follow Widget
  • AddThis Social Bookmarking Widget
  • AddThis Welcome Bar
  • Jetpack by WordPress.com
  • Visual Form Builder
  • WordPress SEO

I select them, press Update, Wordpress loads through it's update procedure:

The update process is starting. This process may take a while on some hosts, so please be patient.

Enabling Maintenance mode…

All updates have been completed.

and then I see that I still have 6 updates available, and the updates have not been applied to these 6 plugins.

I have not made any changes to Wordpress, and deactivating plugins does not resolve this.

I receive no errors, and the hosting plan we're on is unlimited disk space.

share|improve this question
    
no if there where no permission wordpress would not even try to update and then say they are updated! –  James Mitch Mar 4 '13 at 22:10
    
are you sure James? I doubt this –  Steve Mar 6 '13 at 6:15
1  
It would be helpful to see the request parameters. Use the Chrome developer tools network panel to view the request. It should be a POST to update-core.php?action=do-plugin-upgrade (though I'm using multisite to test this so it might be a little different for you). The form data should look something like, upgrade=Update Plugins&checked[]=some-plugin/some-plugin.php&checked[]=another_plugin/another_p‌​lugin.php. Is there anything non-traditional about your WP installation, like symlinking the plugins directory? –  Matthew Boynes Mar 7 '13 at 21:37
    
@Steve yes I am sure, WordPress asks for FTP credentials and lets you do it the ftp way and not even tries to write the files with if there is no permission. –  James Mitch Mar 8 '13 at 3:34
    
@JamesMitch: add an answer; I think you're right. –  Steve Mar 10 '13 at 10:51
add comment

5 Answers 5

did you install memcached or apc plugin? If you did, remove them and try it. Probably its caching problem.

Update: I am not sure if this is your case but i was facing this problem when i try to use apc for opcode caching. Basically main problem is fcgi prosesses are not using same cache pool. Here is more details: https://bugs.php.net/bug.php?id=57825 What can i suggest: dont use opcode cache or use memcached for opcode caching.

Update2: It seems we are getting another alternative to apc.. Optimizer+: https://twitter.com/unsalkorkmaz/status/309736703852154880

share|improve this answer
    
I use W3 Total Cache, which is front end caching I believe. –  Steve Mar 6 '13 at 6:14
    
Please try to disabled w3 total cache and try update. If it works, probably your hosting company using FCGId or CGI wrapper thats cousing problem with apc opcode caching. –  Ünsal Korkmaz Mar 6 '13 at 12:16
add comment

Here is how to solve/determine the problem.

Download the plugin files and update them manually through FTP.

If the problem persists. Disable all plugin files except ones that need to be updated.

Try again to update.

If problem persists disable all plugins and update one by one. If you have a plugin conflict you should really try to find the problem plugin because it could cause other problems later that you don't know about know.

If problem persists change the theme and try to update again.

If WordPress still says they need to be updated download the WordPress core files for 3.5.1 and overwrite core files only. Be sure not to overwrite your Wp-config file and .httaccess file intact so you don't have to change the settings for your network.

These are the steps to always take if you ever have any problem with your plugins or themes.

If none of this solves your problem. There is definitely some sort of caching problem and you should contact your host.

share|improve this answer
add comment

James Mitch's comment prompted me to remember that I recently moved this website's host.

I don't think I updated the FTP information. I will check this tomorrow.

share|improve this answer
    
I have a answer added now let me know if I am right. –  James Mitch Mar 10 '13 at 11:15
add comment

So lets see if I accidentally got this figured out just by proving @Steve 's comment wrong

So you maybe had typed in the wrong ftp creditials for another server, wordpress uploads this plugins to the ftp what is on another server, then is thinks the plugins are updated, tells you that and then they are not (on this server)?

In case I am right here is the answer to accept ;)

share|improve this answer
add comment

If you don't mind me asking, what is your hosting company? Do they feature caching like memcache or varnish? I would be leaning towards a caching issue, strange ghosting issue. Have you tried clearing browser cache (like Ctrl + F5)? Have you checked to see if the plugin files were actually overwritten? One way is to go in to the plugin file and find the header comments, look at the version written to the server (via FTP, SSH, etc) and compare that to the current version on WordPress.org plugin page.

share|improve this answer
    
This is just a comment or a request for clarification. Please write a proper answer. –  toscho Mar 6 '13 at 19:24
    
-1 asking q in answer –  James Mitch Mar 10 '13 at 23:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.