Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

i want to add this part to wordpress page but every time i add it wordpress add extra stuff that stop it from working properly this is my code

<li data-hovercolor="#e859c5">
                <a href="/digitalways/?page_id=308">
                    <h2 data-type="mText" class="sti-item">server</h2>
                    <h3 data-type="sText" class="sti-item"></h3>
                    <span data-type="icon" class="sti-icon sti-icon-server sti-item"></span></a>
            </li>
            <li data-hovercolor="#0f96c3">
                <a href="/digitalways/?page_id=448">
                    <h2 data-type="mText" class="sti-item">program</h2>
                    <h3 data-type="sText" class="sti-item"></h3>
                    <span data-type="icon" class="sti-icon sti-icon-hardware sti-item"></span>
                </a>
            </li>

this is how wordpress make it

<li data-hovercolor="#e859c5">
<a href="/digitalways/?page_id=308">
<p></p>
<h2 data-type="mText" class="sti-item">server</h2>
<h3 data-type="sText" class="sti-item"></h3></a>
<p><a><span data-type="icon" class="sti-icon sti-icon-server sti-item"></span></a></li>
            </li>
share|improve this question
    
if you can Try to keep it in div tag. –  Vinod Dalvi Feb 27 '13 at 10:58
add comment

1 Answer 1

up vote 0 down vote accepted

Add this to your functions.php, this should give the result you're looking for:

remove_filter('the_content', 'wpautop');
share|improve this answer
    
thaaaaaaaaanks alot you are really a life saver –  sarah Feb 27 '13 at 11:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.