WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am working on a website that I installed WP on a few months back but haven't worked on beyond the install of WP and a theme. I went back to it today and needed to update WP and install a few plugins.

When I went to do that it started asking me for FTP info, which was new to me. After research I added said FTP info into the wp-config file. Now when I go to update WP or install a plugin, where it should start putting info on the screen about downloading and updating the files I get nothing in the right pane of the dashboard.

I've tried chmod wp-content to 777 and still nothing. I can FTP but I need to be able to update via WP.

I'm stumped. Any thoughts?

share|improve this question

migrated from stackoverflow.com Feb 26 '13 at 19:18

This question came from our site for professional and enthusiast programmers.

up vote 5 down vote accepted

Wordpress is only asking for FTP credentials if your chmod permissions are misconfigured. You should start by checking them. It means all files and directories inside wordpress dir and not only wp-content.

share|improve this answer
To isolate the problem I'm only working on adding a plugin now. Everything is showing 775 for the WP folder, including the plugins folder. I removed the FTP info from the wp-config file, back to asking for FTP login info. – Chris Cummings Feb 26 '13 at 15:54
Is your apache instance running as the same user as your permissions are set to? – fliespl Feb 26 '13 at 16:03
Checked it and it is using same user permissions. – Chris Cummings Feb 26 '13 at 16:04
Further digging of the hosting company (that gets good reviews but I don't particularly care for) shows others saying you can't use auto updates of WP here and possibly having to use CGIwrap. Looks like its not a chmod issue but a hosting company issue. I think your answer will be most helpful to others though and it helped me find my answer, so I am marking it as correct and voting it up. – Chris Cummings Feb 26 '13 at 16:14

When you are trying to update your WordPress installation be sure to disable all your plugins first. I had several problems when i've not disabled these, plugins for backups above all.

share|improve this answer
No plugins active – Chris Cummings Feb 26 '13 at 15:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.