Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a working, self-hosted Wordpress install residing in my webspace at crypticname.online.de/Mysite/ and acquired a domain, let's say mysite.de. I would like mysite.de to request the home page of crypticname.online.de/Mysite/ and mysite.de/photos/ -> crypticname.online.de/Mysite/photos/ but without actually changing the url in the browser to the cryptic address.

The respective pages in the Wordpress codex only explain how to move a site from one location to another but I didn't find a solution to this particular problem. What kind of settings do I need to set in the Wordpress backend and at my domain name provider?

share|improve this question
    
This isn't a specific wordpress question. It would be more on topic on StackOverflow (or another site?). To point you in de right direction: you'll have to set the DNS records of mysite.de to the old URL. –  Camil Staps Feb 25 '13 at 16:41
    
I thought the whole process would include changing settings in the Wordpress backend, so I posted it here. –  Christoph Feb 25 '13 at 16:49
    
Depending on the solution this is a WordPress question, because WordPress will redirect the address to the canonical URL in some setups. –  toscho Feb 25 '13 at 17:13
    
@toscho Oh, sorry, didn't know that. –  Camil Staps Feb 25 '13 at 17:42

2 Answers 2

The easiest way to handle this is to let your domain point to the WordPress directory, in your case: /mysite from your root web folder. This usually can be done either by your hoster or in your cPanel/administration tools.

You also have to change WordPress Url and Site Url in your WordPress Settings to your new Domain.

If you have no way of changing the directory your domain points to on your server, you can COPY (not move) the index.php from your WordPress folder to your root directory, as well as the .htaccess.

Inside the index.php in your root directory you have to change the include path of wp-blog-header from

require('./wp-blog-header.php');

to

require('./MySite/wp-blog-header.php');

And change the WordPress Url in your WordPress Settings to http://www.mysite.de/MySite, so WordPress knows that it's files are located in a Subdirectory.

share|improve this answer
    
Thanks for your answer, I think the point where I'm stuck is "point to the WordPress directory". My domain name provider (United Domains) provides different ways, two of them (one of them is probably the right one) are "Header Redirect" and "URL Hiding". Do you have any advice on which one to take? –  Christoph Feb 25 '13 at 19:08
    
As your webspace provider and domain provider are not the same, I would suggest solution two. You can either set the ARECORD of your domain to the IP of your webspace provider, and set up the domain there, or you use the URL Hiding. But this discussion is OffTopic here - I'd ask at StackExchange for the Setup of your Domains, and use this answer to configure your WordPress Setup. –  fischi Feb 25 '13 at 19:32
    
To get ontopic again: I have isolated the problem to the Wordpress side of the story. When I use URL Hiding to point to the correct directory on the server and use www.mysite.de as both WordPress URL and Site URL, the home page of the blog is loaded when I enter www.mysite.de, but it says "No posts found" and I can't access any other pages of the blog, e.g. www.mysite.de/wp-config.php. Looks pretty bad until there but I noticed that some records from the DB are loaded through a custom function I wrote to retrieve gig dates from the plugin "Tribe Event Calendar". –  Christoph Feb 25 '13 at 20:12

Lol i'll tell you what i would do: i'd use XCloner plugin (case sensitive search on install plugins menu), create a domain in my host like i would normally do and then use the "clone' function in XCloner to install the wordpress in the new dir, it works great.

first, register the new domain under your host. It will generate a folder for it, right?

  1. Install 'XCloner' trought wordpress admin
  2. acess XCloner under plugins menu
  3. login admin/admin
  4. generate a backup
  5. if you'll overwrite a mySQL db, make sure you select "add Drop Sintax"
  6. after generating the backup, click on CLONE blue button upper-right
  7. put your ftp details.. attention for the folder, should be like htdocs/mysite , or the path you use by ftp to enter your new domains folder1
  8. click clone (wait for upload, it has no progress bar, you can watch the progress trough your ftp client)
  9. after sucessfully uploaded, you'll put you DB info.... then it will work under your new domain
share|improve this answer
    
really -2? what for? it should solve the guys problem ¬¬ i have nothing to do with this plugin development, i just use it (a lot) –  user1576978 Feb 25 '13 at 17:43
    
There is no explanation on how this works, as well as it does not cover what Settings have to be set, as asked. –  fischi Feb 25 '13 at 17:44
    
got it, sorry. But it would solve his problem anyways –  user1576978 Feb 25 '13 at 17:49
    
i'll try to improve the awnser –  user1576978 Feb 25 '13 at 17:50
    
Unfortunately my domain provider and my webspace provider are not the same - this means I do not have webspace at the company that provides my domain name. –  Christoph Feb 25 '13 at 18:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.