Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

This is the website

This is what the login http://wayfaroutadventures.com/blog/wp-admin/&reauth=1">looks like now

Basically here's what happened:

I had www.mysite.com/blog as the permalink instead of www.mysite.com, and /blog wouldn't go away. So then I changed it so it was .com without blog and it not won't let me login or anything, gives me a 404. I'm scared because I think I seriously screwed up and I don't know how to fix it! How do I get it so I can login again. I don't even care if its /blog anymore. I just want my site back.

share|improve this question
add comment

1 Answer

You can still get to your login page: http://wayfaroutadventures.com/blog/wp-login.php You probably haven't done any serious damage.

Login to your site over FTP or using some file manager provided by your host and add:

define('WP_SITEURL', 'http://example.com/wordpress');
define('WP_SITEURL', 'http://' . $_SERVER['HTTP_HOST'] . '/path/to/wordpress');

See: http://codex.wordpress.org/Editing_wp-config.php#WordPress_address_.28URL.29

Of course, the addresses need to match exactly what you had before you changed things. That should get you operating again.

Reference:

http://codex.wordpress.org/Editing_wp-config.php#WordPress_address_.28URL.29

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.