Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I use womanish theme
and I install the all in one seo pack , but I see two meta tags for keyword and description in source code,I can't find the related code in header.php or top.php, How can I fix that?

I can not resovle my problem, Is it will be a bad impact in seo?

share|improve this question
    
This is difficult to answer given the information provided. Switch to a default them, disable all of your plugins one by one, (except the seo one) and see if you can't narrow down the problem –  s_ha_dum Feb 22 '13 at 19:56
    
when I switch to default theme I don't have two maeta tags –  Olive Feb 23 '13 at 16:10
add comment

1 Answer

From what I see on that theme it would not be in header.php. It would be related in the theme since it already has an SEO optimization feature built in. You need to go through the functions.php and seek SEO and remove modify this line:

$default='global|slider|layout|seo|translations';

to

$default='global|slider|layout|translations';

Which will remove the setting to be included to the options. If this does not work go into inc/settings.php and remove line 368-402 which should look like:

'seo'=>array(
        'name'=>'SEO',
        'content'=>array(
            'description'=>array(
                'type'=>'text','name'=>'description','value'=>'','ttl'=>'Site description'              
            ),
            'keywords'=>array(
                'type'=>'text','name'=>'keywords','value'=>'','ttl'=>'Site keywords'                
            ),
            'authormeta'=>array(
                'type'=>'text','name'=>'authormeta','value'=>'','ttl'=>'Site Author Meta'
            ),
            'category'=>array(
                'type'=>'check','name'=>'category','value'=>'0','ttl'=>'‹noindex› in category archives', 'hint'=>'Turn on to prevent all robots from indexing a category page on your site'
            ),
            'tag'=>array(
                'type'=>'check','name'=>'tag','value'=>'0','ttl'=>'‹noindex› in tag archives', 'hint'=>'Turn on to prevent all robots from indexing a tag page on your site'
            ),
            'author'=>array(
                'type'=>'check','name'=>'author','value'=>'0','ttl'=>'‹noindex› in author archives', 'hint'=>'Turn on to prevent all robots from indexing a author page on your site'
            ),
            'search'=>array(
                'type'=>'check','name'=>'search','value'=>'0','ttl'=>'‹noindex› in search archives', 'hint'=>'Turn on to prevent all robots from indexing a search page on your site'
            ),
            'day'=>array(
                'type'=>'check','name'=>'day','value'=>'0','ttl'=>'‹noindex› in day archives', 'hint'=>'Turn on to prevent all robots from indexing a day archives page on your site'
            ),
            'month'=>array(
                'type'=>'check','name'=>'month','value'=>'0','ttl'=>'‹noindex› in month archives', 'hint'=>'Turn on to prevent all robots from indexing a month archives page on your site'
            ),
            'year'=>array(
                'type'=>'check','name'=>'year','value'=>'0','ttl'=>'‹noindex› in year archives', 'hint'=>'Turn on to prevent all robots from indexing a year archives page on your site'
            )
        )
    ),

These steps will remove the default theme SEO which will in return get rid of your duplication meta problem. Hope this helps.

share|improve this answer
    
I did your solution, but But extra metas were not removed, I still have two meta tags. –  Olive Feb 22 '13 at 20:21
    
You might want to download a copy of your files and search through them for any meta fields. –  Jon Tyler Long Mar 12 '13 at 15:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.