Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When you access mysite's feed you get the error message shown below. I've checked my functions.php file that no have any extra space on bottom end of file.

error on line 1 at column 6: XML declaration allowed only at the start of the document Below is a rendering of the page up to the first error.

share|improve this question

closed as off-topic by kaiser Sep 5 at 8:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
Please add debugging debugging information. Disable all of your plugins and see it that helps. Switch to a default theme and see if that help. –  s_ha_dum Feb 13 '13 at 1:10
    
i've installed wp cache plugin after asking question i've deleted plugin and its work fine.... but how i can keep both, wp cache plugin and feed functionality. –  Rameez SOOMRO Feb 13 '13 at 7:55
    
Closed as it in fact is a plugin support question. –  kaiser Sep 5 at 8:16

2 Answers 2

http://cameron.ghost.io/fixing-rss-feed-in-wordpress/

follow the instructions here from the theme directory. This issue is caused by whitespace somewhere in your php files. There is a single terminal command to fix.

share|improve this answer
2  
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  TheDeadMedic Sep 5 at 7:38
    
As you see I'm new to Stack Exchange. Will remedy in my next answer –  cbanowsky Sep 6 at 20:13

This sounds similar to a problem I had with my RSS feed

just as @s_ha_dum suggests it could be theme or plugin related:

a) is it a theme related problem? --> switch to the default theme 2012 to check. if yes: You should also check if you have empty lines in between your code in functions.php:

 ?>

 <?php

or if there are some direct echos. In my case it was an empty line at the bottom of functions.php after ?>, so I now don't use ?>to close <?php at the end of the functions.php.

b) is it a plugin related problem? --> deactivate your plugins to check since some plugins can output empty lines. if yes: then activate your plugins, one by one to find the problematic plugin.

ps:

To debug my RSS feed I like to use

http://feedvalidator.org

and remember to remove feed caching if you have one.

share|improve this answer
    
i've installed wp cache plugin after asking question i've deleted plugin and its work fine.... but now how can i keep both, wp cache plugin and feed functionality. –  Rameez SOOMRO Feb 13 '13 at 7:56
    
I have used wp-super-cache, w3tc and hypercache without any RSS problems. –  birgire Feb 13 '13 at 9:29
    
Hi, noticed you have unaccepted the answer few months later, can you elaborate on that? –  birgire Jul 17 '13 at 10:36
    
because i won't found solution of my problem in this answer sorry... –  Rameez SOOMRO Jul 17 '13 at 20:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.