Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have set up a category called 'blog' and have all of my posts displaying from this category. I have selected to display 4 posts / page therefore there is a link at the bottom that says older entries. However, when I click on "older entries" button, it takes me to the store page. I think the url is causing this problem but I have spent the whole night last night to figure it out and I still haven't found a solution yet.

My website is: www.talis.com.au

My blog is: www.talis.com.au/?cat=28 (how to change it to www.talis.com.au/blog?)

share|improve this question

1 Answer 1

Go into Settings > Permalinks, and change the Permalink to a Custom Structure:

/%category%/%postname%

You may need to update your Menu in Appearance > Menus also.

share|improve this answer
    
Hi, thanks for your reply. This is what I've got after changing it. talis.com.au/category/blog –  Natalie Feb 11 '13 at 4:40
    
@Natalie: Hmm, I can see there are no entries on page 2. I assume you have more than 4 entries in the Blog category? –  Steve Feb 12 '13 at 5:22
    
Try creating a blank page called Blog, and then setting that page to be your posts page in Settings > Reading. You'll have to add it to your menu also. –  Steve Feb 12 '13 at 5:25
    
I've tried what you've mentioned above. However, what's showing on my blog page is the same as the home page. Is there anything missing when I am doing this? What I've done was: –  Natalie Feb 13 '13 at 11:42
    
1. Created a php file called blog.php 2. Set up a page called "My Blog" 3. Used "My blog" as posts page 4. Added "My blog" to main menu –  Natalie Feb 13 '13 at 11:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.