Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

The insertion of ?doing_wp_cron in Wordpress’s URL is very well documented here.

My problem is a little different. I turned on the ALTERNATE_WP_CRON feature in my wp-config file a few days ago. Then, noticing this issue –i.e. the introduction of ?doing_wp_cron in my URLs– I disabled it. And by “disabled” I mean I completely removed it from the wp-config file. I did this 36 hours ago.

My problem is that ?doing_wp_cron is still showing up in my access log. I wonder why? My two hypothesis are:

1) I should not remove ALTERNATE_WP_CRON but instead I should give it the value FALSE

2) Those URLs are in some browsers cache and being served as such. With time they should disappear.

Feedback will be appreciated.

P.

share|improve this question
    
Ok, without being sure about this, I think I found an explanation. I believe those are normal occurrences simply indicating that WordPress cron jobs are working. In my access log, they are always associated with POST request, not GET request and with the general URL of my website, not with specific posts. And I haven’t seen them in my URLs since I’ve disabled the ALTERNATE_WP_CRON Can somene familiar with access log confirm? Thanks. –  Parneix Feb 10 '13 at 18:13

1 Answer 1

up vote 0 down vote accepted

I have confirmed with my host that this is a normal occurrence in access logs when running WordPress crons. Also, since I disabled ALTERNATE_WP_CRON I didn’t come across any actual (live) URLs with the ?doing_wp_cron attached to them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.