Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've moved my blog from http://leghumped.com/blog to http://leghumped.com/ and now I can't access my /images directory. I've tried every combination of rules from trawling for people with the same problem, but it seems most of them say it "just started working".

This is my root .htaccess

# BEGIN WordPress>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_URI} !^/images/
RewriteCond %{REQUEST_URI} !^/images
RewriteCond %{REQUEST_URI} !.*images(.*)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
RewriteRule ^index\.php$ - [L]

# END WordPress
RedirectMatch wp/(.*)$ http://leghumped.com/$1

I know I'm typing the filename correctly, but I can't access anything in /images.

share|improve this question

3 Answers 3

Comment out the following by adding hash tags before it

#RewriteCond %{REQUEST_URI} !^/images/
#RewriteCond %{REQUEST_URI} !^/images
#RewriteCond %{REQUEST_URI} !.*images(.*)

and see if that helps.

share|improve this answer

also something to try, change: "Site Address (URL)" in Settings > General. If you can't access it because of the move you can do it via accessing the database as well.

share|improve this answer

Your question is kinda vague, do you mean no access through FTP or through the backend of WordPress?
(You mean the images which are directly part of the theme you use? or the uploaded images?)

Anyway, I checked your website and see that you moved the folder uploads and renamed it to images! So it "lives" in your root now (public_html/images).
Assuming topic is about the renamed uploads folder which is moved to the root.

Please be aware of what you doing and backup those 3 files first before editing.
(.htaccess / wp-config.php and functions.php)

Imho it is incorrect trying to solve this issue through your .htaccess!
Following is what I would try/do.

Start with deleting these 3 lines in .htaccess or as gteh advised to do

RewriteCond %{REQUEST_URI} !^/images/
RewriteCond %{REQUEST_URI} !^/images
RewriteCond %{REQUEST_URI} !.*images(.*)

1)Edit wp-config.php and add following code:
Maybe a little overdone but to be sure your settings are correct first 2 lines helps telling Wordpress the path, by adding the third codeline you tell Wordpress where your Uploads folder is and which name it has.
(Be aware by adding the first 2 code lines you won't be able to edit them on the General settings page anymore)

define('WP_HOME','http://leghumped.com');  // NO trailing slash at the end
define('WP_SITEURL','http://leghumped.com'); // NO trailing slash at the end
define( 'UPLOADS', 'images' );  // NO trailing slash at the end 

Check if the images are visual in Media (Backend worpress), if it is showing your images your done and could stop reading now :)

If still not visable following steps could help you little more:
2) Edit *functions.php in your theme folder!* and add following code:

update_option('home','http://leghumped.com');// NO trailing slash at the end
update_option('siteurl','http://leghumped.com');// NO trailing slash at the end
update_option('upload_url_path', 'images');// NO trailing slash at the end

Hope this solves your problem.


Note to mods: question was/is from 8 febr. and now it shows up again?! So therefore my late responce/answer. If incorrect please delete this answer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.