Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

For uploading files bigger than 58meg I get HTTP error. or IO error when using media uploader or 500 Internal Server Error when using browser uploader in WordPress v3.5.1 Multisite . It seems to get almost all the way thru the upload before it stops and comes back with the error message. Hosting is LINUX thru Godaddy, they tested a php script to load a 130meg file successfully they can not find anything wrong, I get the error in IE9 or Firefox with or without flash plugin, cache cleared or not, only with files larger than 58megs, mod security fix does not seem to work for this issue either. FTP works fine to upload larger files and uploading files smaller than 58megs works fine, This is a multisite configuration and the errors happen for every site, I do not have any plugins loaded yet, Does anyone have any ideas about how to fix this?

my php5.ini file is this:
max_execution_time = 1800
max_file_uploads = 2000
memory_limit = 256M
post_max_size = 192M
file_uploads = On
upload_max_filesize = 192M

my .htaccess file now is:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ $1 [L]
RewriteRule . index.php [L]

</IfModule>

# END WordPress

part of my wp-config.php file is:

/* Multisite */
define('WP_ALLOW_MULTISITE', true);

define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', true);
define('DOMAIN_CURRENT_SITE', 'youmightry.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

define('WP_MEMORY_LIMIT', '256MB');

thank you for your editing and your comments! :) great ideas! I forgot to mention that my hosting is Linux hosting.. and I am looking into my settings.php file
here is the upload settings section

 </table>
    <h3><?php _e( 'Upload Settings' ); ?></h3>
    <table class="form-table">
        <tr valign="top">
            <th scope="row"><?php _e( 'Site upload space' ) ?></th>
            <td>
            <label><input type="checkbox" id="upload_space_check_disabled" name="upload_space_check_disabled" value="0"<?php checked( get_site_option( 'upload_space_check_disabled' ), 0 ) ?>/> <?php printf( __( 'Limit total size of files uploaded to %s MB' ), '</label><label><input name="blog_upload_space" type="number" min="0" style="width: 100px" id="blog_upload_space" value="' . esc_attr( get_site_option('blog_upload_space', 100) ) . '" />' ); ?></label><br />
            </td>
        </tr>

        <tr valign="top">
            <th scope="row"><label for="upload_filetypes"><?php _e( 'Upload file types' ) ?></label></th>
            <td><input name="upload_filetypes" type="text" id="upload_filetypes" class="large-text" value="<?php echo esc_attr( get_site_option('upload_filetypes', 'jpg jpeg png gif') ) ?>" size="45" /></td>
        </tr>

        <tr valign="top">
            <th scope="row"><label for="fileupload_maxk"><?php _e( 'Max upload file size' ) ?></label></th>
            <td><?php printf( _x( '%s KB', 'File size in kilobytes' ), '<input name="fileupload_maxk" type="number" min="0" style="width: 100px" id="fileupload_maxk" value="' . esc_attr( get_site_option( 'fileupload_maxk', 300 ) ) . '" />' ); ?></td>
        </tr>
    </table> 
share|improve this question
1  
I guess you have also checked "Upload Settings" here /wp-admin/network/settings.php ? –  birgire Feb 8 '13 at 10:48
    
This is a wordpress multisite, I wonder if I create a site or the original site? before I had changed the upload limit settings then the earlier site would still have the old low limit on uploads? I am not sure where to look or how to fix this though, maybe start over? but where do I put the modified setting when I am creating the original site, am I on the right track here? –  Adam Collegeman Feb 9 '13 at 8:47
    
will you take another look at my question and see if you have anymore ideas about how to solve this? I think I will reload the whole site and do it myself manually this time just to start fresh and see if that helps, thank you –  Adam Collegeman Feb 17 '13 at 6:54
    
What are the files? Images? Or ZIP Files? Or what? –  Otto Mar 3 at 22:28
add comment

1 Answer

Some ideas:

  • You should check your php info, just to verify your upload settings (<?php phpinfo();?>)

  • You could try a single install, to see if you have the same problems as with multisite.

  • You should also try some 3rd party upload script yourself.

  • In /wp-includes/script-loader.php I found these lines:

    // common bits for both uploaders
    $max_upload_size = ( (int) ( $max_up = @ini_get('upload_max_filesize') ) < (int) ( $max_post = @ini_get('post_max_size') ) ) ? $max_up : $max_post;
    
    if ( empty($max_upload_size) )
            $max_upload_size = __('not configured');
    

so it is using the minimum of upload_max_filesize and post_max_size. It looks though you have these variables as set as 192MB > 58MB.

share|improve this answer
    
I reloaded site manually as a single install with the php5.ini file you see above, I still get the same error, I will look at your other suggestions next, thank you! :) –  Adam Collegeman Feb 23 '13 at 20:14
    
I did the php info check, is there a way to post it here? –  Adam Collegeman Mar 1 '13 at 8:43
    
I have tried increasing the network settings file sizes in wordpress network dashboard, I have tried putting various php5.ini files in the root folder and in other folders also, I have tried adding commands to .htaccess such as the setenv phprc or php_value, they do not seem to make a difference either, I still get the same error message and the same limit of 58megs, it still seems to get to the end of the file upload and then stops and give an error message –  Adam Collegeman Apr 2 '13 at 4:22
    
Do you get any error messages in the php/apache logs? You should keep a list of what you have tried so you can undo it later ;-) Maybe more ideas here: wordpress.stackexchange.com/questions/59763/… –  birgire Apr 2 '13 at 5:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.