Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am getting a white screen that just says 'error' on it. I have removed all plugins, re-installed the theme and also re-installed wordpress. The website will work fine when going to the homepage, but as soon as I click on another page or category it returns this white screen.

Has anyone else seen this?

share|improve this question

closed as too localized by toscho May 11 '13 at 22:15

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Have you enabled WP_DEBUG? If not, enable it, and report any fatal error messages generated. If you already have it enabled, check your server error logs, and report any fatal error messages there. –  Chip Bennett Feb 8 '13 at 0:38
    
Can you post an URL? –  s_ha_dum Feb 8 '13 at 1:25
    
Read Debugging in WordPress, then set WP_DEBUG and WP_DEBUG_LOG so that you can find out what the errors are. –  webaware Feb 8 '13 at 4:05
add comment

3 Answers 3

you may also check for whitespace at then end of functions.php file or more specifically white space above the opening If you start over with all new installs the only possible issue would be on your machine, bug of some sort.

share|improve this answer
add comment

Could be a problem with your .htaccess. Check the permalink settings, change to something else and hit save. If there is an error, there's your problem.

It could also be with the theme. Try out another theme (such as the default) to see if any error appears.

share|improve this answer
    
It's not the theme or the .htaccess I have tried all of this. I've just discovered that the site will work fine in firefox, but as soon as I open it in chrome, it will give the error. And then I try opening in firefox agian and get the error. It's very odd –  user537137 Feb 8 '13 at 0:28
    
Browsers are unrelated to this problem until you are getting pages from browser cache. Can you access the admin area? –  Max Yudin Feb 8 '13 at 9:00
add comment

Change the line in wp-config.php from

define('WP_DEBUG', false);

to

define('WP_DEBUG', true);

and see what information shows up.

share|improve this answer
    
This is a Comment, not an Answer. And as a matter of fact, it's the first Comment made to the Question 19 hours ago... –  brasofilo Feb 8 '13 at 20:34
    
sorry, I am new to StackExchange ... how do you add a comment to new question? I do not see an option to add a comment except after I've added an answer and someone commented. –  J. Chin Feb 9 '13 at 0:41
    
Take a look at this: faq. As a matter of fact, you'll earn your first badge after reading all the FAQ ;) –  brasofilo Feb 9 '13 at 0:44
    
thanks ... I'll go read that now ... didn't find that before –  J. Chin Feb 9 '13 at 0:48
    
guess I am too new of a user to comment on existing questions that don't already have comments, I need like a 50 reputation, so sorry for posting it in an answer –  J. Chin Feb 9 '13 at 0:53
show 1 more comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.