WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have higher PR as a result of that lots of spammers make trackbacks, everyday I have to delete them.

Those trackbacks will negatively affect my site SEO? How do I disable my site all the posts trackback at once?

I have run following code in my MySQL admin and WotdPress manage DB plugin,, it show me an error.

UPDATE wp_posts SET ping_status='closed' WHERE post_status = 'publish' AND post_type = 'post';

UPDATE wp_posts SET ping_status='closed' WHERE post_status = 'publish' AND post_type = 'page';

share|improve this question
I think you can solve this problem by reading the answer to this question. If it still doesn't work for you, then let us know. – Bart Karp Feb 5 '13 at 18:45
You never said which error. That's pretty important when asking a Question. – brasofilo May 26 '13 at 2:59

This can be solved using the Bulk Edit WordPress functionality.

bulk edit


editing bulk edit

Change the number of items to be shown in Screen Options, so you can select all posts/pages at once.

Two things worth noting in the Q&A pointed by @BartKarp:

  • There is the option to turn off trackbacks/pingbacks under Settings > Discussion.

  • it has a link to a plugin by @chrisguitarguy. If you want to implement total blockage of trackbacks, use chris'.

share|improve this answer
Thank you so much brasofilo. But I have more than 500 posts. Are there any quick method? – Chathu May 26 '13 at 2:49
Well, writing a custom routine to get all posts, iterate through them and update the info. But the time involved in writing, testing and finally doing it, would be greater than going through the interface. Change the Screen Options to show 50 or 100 posts at a time, and it will be a breeze. I don't recommend setting a greater value as it'd be too much overload to the server. Surely, you can find the correct SQL query and go through PHPMyAdmin. – brasofilo May 26 '13 at 2:57
I don't see Pings in Bulk Edit now, only Comments :( – sam Aug 26 '14 at 13:56

SQL Query

DELETE FROM `wp_comments` WHERE `comment_type`=”trackback”

Run Query from this plugin: wp-dbmanager

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.