Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm getting trouble with another permalink setting then the default permalink setting.

I want to use the post name of a page/article but when I activate "the post name", all of my pages, except the home page, is not working. (all 404-pages).

Steps taken:

  1. Clean install
  2. clean twenty x theme

I think it is again a server issue like in my other post: http://wordpress.stackexchange.com/questions/84151/unable-to-search-install-plugins-via-loged-in-admin

Does somebody knows what I can do about this problem. Btw, I'm not working in the root directory on my server. I copy the wordpress folder into the HTTPdocs folder on my server.

share|improve this question

put on hold as off-topic by toscho yesterday

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
Have you created .htaccess file? –  Max Yudin Feb 2 '13 at 11:30
    
Max, I've created nothing. I didn't know it was necessary because I also have another webserver, by another company, and there everything is working very well. –  Niels Jansen Feb 2 '13 at 11:37

1 Answer 1

Create a file in HTTPDocs named .htaccess (notice the preceding dot!) with following contents:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

When you where creating your permalinks and saving changes there was visible information about it.

If still does not work, check if mod_rewrite is enabled. To do this place following code after <?php in your theme's functions.php:

if( !in_array( 'mod_rewrite', apache_get_modules() ); )
    echo 'mod_rewrite disabled';

Refresh your front page and if you see mod_rewrite disabled on top on your screen, then call your hoster to enable it.

Now you can remove that code.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.