Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

This is a terrible user experience when I'm trying to do the most simple thing and it never works. There are many pages with "instructions" how to do this and none of the "instructions" work.

Now we hate Wordpress for making the most simple thing just not possible.

## Solution ##

This only worked when doing it via the quick-edit which is disastrous since there no instruction that says so. We should get our money back for this crap.

share|improve this question
add comment

closed as not a real question by Michael, s_ha_dum, brasofilo, toscho Feb 2 '13 at 7:22

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

up vote 2 down vote accepted

WordPress admin screen -> Settings -> Discussion -> "Allow people to post comments on new articles". Uncheck it.

For existing posts, go to Posts -> All Posts. You can click "Quick Edit" on any post to find the "Allow Comments" checkbox and turn them off for that post.

To bulk-edit existing posts, you can select all the posts you want to edit at once using the checkboxes, then use the "Bulk" feature at the top of the page. Select "Edit" from the dropdown, click Apply. Then in the bulk editor, change the Comments dropdown to "Do not allow" to change that setting on all the selected posts.

This applies to any theme, it is not specific to Twenty Ten.

share|improve this answer
    
Been there, done that and of course Wordpress is not working like that. This is the most terrible internet experience of my life. –  909 Niklas Feb 1 '13 at 22:00
    
Umm.. What problem are you experiencing, exactly? Because that does work and is the correct answer to your question. If you have some kind of problem, then being more specific about the problem will get you more specific answers. –  Otto Feb 1 '13 at 22:03
3  
NM, just saw your edit. For reference, comments can be turned on/off on a per-post basis. So if you were just disabling it for new articles, then it would not be disabled for existing articles. Also, WordPress is completely free, so here's your $0.00 back. Spend it wisely. –  Otto Feb 1 '13 at 22:05
    
There is no instruction that says the quick edit overrides everything else. I say the Wordpress AdminUI is the greatest disaster in the history of UI. I paid for custom. –  909 Niklas Feb 1 '13 at 22:06
1  
The Quick Edit does not "override everything else", it only changes the properties of a single post. There is no global "comments-on/off" field in WordPress, individual posts have their own settings. –  Otto Feb 1 '13 at 22:07
show 2 more comments

I believe this is fairly easy. You can disable comments in your WordPress settings.

Go to your WordPress dashboard -> Settings -> Discussion -> Allow people to post comments on new articles

You can also add the following to your themes functions.php to remove the 'Comments' page from the WordPress dashboard.

function remove_comments() {
    // Remove comments page
    remove_menu_page('edit-comments.php');
}
add_action('admin_menu', 'remove_comments');
share|improve this answer
    
It was ticked in the quick edit where I had to uncheck it. There is no instruction that says the quick edit overrides everything else. I say the Wordpress AdminUI is the greatest disaster in the history of UI. –  909 Niklas Feb 1 '13 at 22:05
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.