Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

My Wordpress Address (URL) in general settings keeps losing the www from the URL - I type in http://www.domain.com and it saves and works fine.

Next time I go in the address has changed to http://domain.com. So again I change it, I get logged out and I log back in and it looks fine until next time and it has changed again.

This is the only setting which changes (site address keeps the www) and I have checked my htaccess and cannot see anything untoward and there are no parked domains etc - any idea what could be causing this?

Most of the time it doesn't cause any issues but sometimes when I visit the site it defaults to the non www version which could be detrimental to SEO as well as it affects my SSL for some secure pages as I only have the SSL for www.domain.com so I would like to fix it if I can.

share|improve this question
    
Disable all of your plugins and try it, and switch to a default theme. –  s_ha_dum Jan 29 '13 at 14:52
    
I was hoping to avoid that as it doesn't happen right away (I have just logged in again and it still shows the www) so that would mean my site would, in effect, be down until it did it again which I want to avoid if I can but it may come to this so thanks for the suggestion –  bhttoan Jan 29 '13 at 15:03
    
It isn't normal behavior so some non-core something is likely the culprit. You have to find out what. If you don't have a development server to do your debugging on that is going to be painful. –  s_ha_dum Jan 29 '13 at 15:50
add comment

1 Answer

Ensure that you haven't defined it in your wp-config.php

http://codex.wordpress.org/Changing_The_Site_URL#Edit_wp-config.php

share|improve this answer
    
I have checked both wp-config and wp-settings and there are no references in either, thanks for the suggestion –  bhttoan Jan 29 '13 at 15:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.