Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a Wordpress site that uses the backup buddy pluggin. It has always worked well when I was on a shared server, but ever since I migrated my site to a dedicated server, I have had many problems getting backups to complete, send to amazon, or both.

A couple of months ago, one of the guys at Hostgator changed some server settings, and then things seemed to work better. Although occasionally, I still have some problems with backups completing and being sent to amazon.

Just last week in an effort to maximize server performance, I had the Hostgator tech guys install APC. The results were blazing fast page loads (in combination with super-cache) beyond what I expected. The downside is backup buddy has almost completely stopped working. We tried adding what seem to be correct apc.filters which exclude directories from the APC cache, but even still ... it doesn't work.

Currently, here is my php.ini configuration for APC:


apc.enabled = 1

apc.shm_segments = 1

apc.shm_size = 64M

apc.optimization = 0

apc.num_files_hint = 4096

apc.ttl = 7200

apc.user_ttl = 7200

apc.gc_ttl = 0

apc.cache_by_default = 1

apc.filters = "-/home/worlitop/public_html/wp-content/plugins/backupbuddy/*"

apc.filters = "-/home/worlitop/public_html/wp-content/uploads/backupbuddy_backups/*"

apc.filters = "-/home/worlitop/public_html/wp-content/uploads/backupbuddy_temp/*"

apc.mmap_file_mask = "/tmp/apc.XXXXXX"

apc.slam_defense = 0

apc.file_update_protection = 2

apc.enable_cli = 1

apc.max_file_size = 10M

apc.stat = 1

apc.write_lock = 1

apc.report_autofilter = 0

apc.include_once_override = 0

;apc.rfc1867 = 0

;apc.rfc1867_prefix = "upload_"

;apc.rfc1867_name = "APC_UPLOAD_PROGRESS"

;apc.rfc1867_freq = 0

apc.localcache = 0

apc.localcache.size = 2048

apc.coredump_unmap = 0

apc.stat_ctime = 0

The result is, as I said, I now have a blazing fast site, but there's NO way to back it up ... scary. I want to keep APC but I desperately want backup buddy to work. What can we do? Please advise.

share|improve this question
Why do you think APC is in fault? And what exactly does it mean "backup buddy has almost completely stopped working"? –  Mark Kaplun Jan 27 '13 at 6:04
Hello Mark and thank you for your reply. Well, before the APC install, backup buddy was almost all right and working, but right after the install, it is now almost all wrong and not working. If you look at the php.ini code above, I/we (hostgator tech guys and I) have put the apc.filters code in order to try to exclude the backup buddy directories from the cache - but it doesn't seem to work. Are the filters in fact correct? From what I have read, the filers aren't so reliable or exact or don't always work. Strange. What do you think? Please advise. –  Steve Doran Jan 27 '13 at 11:51
add comment

2 Answers

Comment was too long....

If you haven't installed the APC object cache plugin (recommended once you fix this problem) all APC does is to compile your PHP code into some internal representation and keep it in memory saving recompiling time of PHP and memory as this code is shared between apache instances.

The filters are there to exclude code from being precompiled therefor the last two filters are pointless as BB probably don't run code from the upload directory.

Unless BB has some strange code being executed when it detects APC, it is unlikely that the problem is specifically related to its code. Something is wrong with your server setup but unless you can show actual error from the error log it is impossible to help.

The only suggestions I can make is to check that your version of APC is compatible with the version of PHP you are running, and whether you have allocated enough memory for PHP.

share|improve this answer
add comment

This is Steve ... the guy who posted this problem to begin. Thanks for your comments, Mark, and thanks for the editing, Lea.

Again, the guys at Hostgator figured it out. As per Craig, a Linux Administrator at Hostgator, he discovered:

"It took some digging but the condition is known as the Endless ping, it is caused in part by HTTP loopbacks being disabled. The server states they are enabled so I'm unsure how that can be. But the resolution was to add the following to your wp-config.php define('ALTERNATE_WP_CRON', true); // Added for ensuring Backup Buddy works correctly I've done this and now your backup buddy is working and APC is still enabled."

Good news and GREAT work!

Thank you Craig and the Tech team at Hostgator!



share|improve this answer
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.