Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've had this problem for a while now; I hoped that it would go away when I moved to my new host but it hasn't. Whenever I try to install or update a plugin or theme, or even update Wordpress, the page will simply say downloading install package ... but that is the only line that ever appears. If I leave it for a sufficient time the operation will complete successfully but Wordpress will only ever display the first step.

I'm running the latest version of Wordpress and everything is up to date. Does any one know why this is happening and how to resolve it?

Thanks in advance

share|improve this question
    
How can you have the latest version of Wordpress while you are having problems with updating Wordpress? Make sure your folders have the right permission. –  RRikesh Jan 26 '13 at 15:34
    
Yes, check all folder permissions and owners (preferable in the host control panel, or in FTP) and to replace all core files, please refer to this troubleshoot guide on how to proceed. –  brasofilo Jan 26 '13 at 15:36
    
Please debugging information and check your server logs if you have access to them. –  s_ha_dum Jan 26 '13 at 15:37
    
@rrikesh I have the latest version because as I said, everything will update successfully, Wordpress just doesn't tell me when it's finished so I have to guess. I will check the folder permissions and server logs anyway –  Andy Jan 26 '13 at 15:47
    
I've just checked and all the permissions seem to correct and there is nothing in the error_log file –  Andy Jan 26 '13 at 15:58

2 Answers 2

For anyone having the same problem I have found the culprit. I can't remember which one it was, but I had an outdated plugin enabled to gzip output. As soon as I disabled that, the problem went away.

I guess that is what you get for using outdated plugins (that hasn't been updated in over 2 years).

share|improve this answer

For me it was as simple as adding

php_flag zlib.output_compression off

to my .htaccess file

or adding

ini_set('zlib.output_compression', 0);

to wp-config.php... To bad it took me 4 hours to figure out :S

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.