Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Fist I was using default option of permalink and everything was fine (speed is ok, my own created theme is working fine) but now I change default structure to post name structure of permalink now I am not getting 404 error but the problems are :

1 - Whole website is loading very slow (pages,post) .

2 - My custom theme is not working fine means styles are not working on single page or single post.

I checked my .htaccess file where the code is :

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wordpress_1/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpress_1/index.php [L]
</IfModule>

# END WordPress
share|improve this question
    
How are you loading your CSS-files? Look at the generated source in your browser, specifically at the href="http://yoururl.com..." part of the line loading your CSS. It should look like yoururl.com/wp-content/themes/your-theme/style.css. –  jzatt Jan 21 '13 at 10:05
    
@jzatt I am loading styles externally using <style type="text/css" src="">. Actually I made my custom theme. And now when I inspect elements with firebug it shows no rule (css) there. –  Bhuvnesh Gupta Jan 21 '13 at 10:07
add comment

1 Answer 1

up vote 0 down vote accepted

What are you typing in the src="xxxxxx"? Do you have the absolute path or relative path to your style?

If your not loading the CSS from your functions.php with wp_enqueue_style you should load it like this in your header to always get the correct URL to the file: <link rel="stylesheet" type="text/css" href="<?php echo get_stylesheet_uri(); ?>">

Update:

If you (for some reason unknown) want to keep your current file structure with the CSS outside your theme folder. Use this code instead: <link href="<?php echo home_url( '/' ); ?>css/style.css" rel="stylesheet" type="text/css" />

share|improve this answer
    
I am typing this in header.php <link href="css/style.css" rel="stylesheet" type="text/css" /> and my css directory is under htdocs/wordpress_1/css/style.css and header.php is in htdocs/wordpress_1/wp-content/themes/mytheme/header.php –  Bhuvnesh Gupta Jan 21 '13 at 10:19
    
That is not the general way of loading a WP-theme style. The CSS-file should be placed in your theme-directory, and then loaded with the code I posted above. If you want to do it your way anyway you must have it like this to get the correct path: <link href="<?php echo home_url( '/' ); ?>css/style.css" rel="stylesheet" type="text/css" /> –  jzatt Jan 21 '13 at 10:27
    
First of all I want to say thank u from my heart u are the only one who did it. Thanks again!!!!!!!! it's working now but after clearing this I need your more help... Will u please tell me how to put css files under the same directory of theme as default is of twentytwelve etc. and My second problem is of speed which is still slow.... how to make it fast as it works for default permalink. –  Bhuvnesh Gupta Jan 21 '13 at 10:34
    
Glad you got it working. To place the CSS in your theme folder, just move the file to your theme directory, and update your href="" to href="<?php echo get_stylesheet_uri(); ?>". As for your other question I think, firstly that you should mark this CSS-question as solved and open a new question/thread. With more specific info on the speed issues. –  jzatt Jan 21 '13 at 10:39
    
ya sure.... thanks!!!!!!! –  Bhuvnesh Gupta Jan 21 '13 at 10:44
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.