Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a large menu containing 10 parent items with roughly 7 child items each that I am trying to build using the WP-admin > Appearance > Menus.

I have nearly all the menu items added but now my wp-admin backend won't save the menu, it keeps timing out and just ending on a blank screen.

I have about 4 more items left to enter but I can't save the menu anymore.

I have tried increasing the php memory in wp-config.php by adding define('WP_MEMORY_LIMIT', '64M');
but it made no change.

Any tweaks or tips to help me get this menu saved, this is the only thing holding the site up and the client is waiting.

Thanks very much! maikunari

share|improve this question
    
    
I've run into the same problem. Complete nightmare. –  Laxmidi Jul 15 '11 at 0:30

7 Answers 7

up vote 3 down vote accepted

You can always try to split your menu into 2 separate menus and then just display them next to each other in your theme. It's far from perfect and doesn't help a bit in understanding the root of your problem but it could help.

You can use it as temporary workaround to GTD before deadline and then dig deep into memory issues or whatever causes your trouble...

share|improve this answer
    
Thanks Maugly, I believe I will give that a try. As you say it doesn't solve the issue but it may be a good work-around. –  maikunari Jan 31 '11 at 19:27
    
PS: Might not be your case but define('WP_MEMORY_LIMIT', '64M'); doesn't work when the obsolete SAFE MODE is in operation. It happened to me some time ago while tweaking one client's website and it drove me nuts before I realized... –  Michal Mau Jan 31 '11 at 19:28
    
Thanks for that tip as well! –  maikunari Jan 31 '11 at 19:32

Try increasing your servers php memory limit by either editing your php.ini or wp-config.php using

define('WP_MEMORY_LIMIT', '96M');

and let us know.

share|improve this answer
    
I found this: link Worked like a charm, it doesn't seem to interfere with the functionality of the page. My best guess is that it hangs because the descriptions are too long. I didnt change the memory limit, but it sounds like it should work too, if anyone tries this and it works ,ill be happy to switch my solution, i dont like messing with the WP core. –  user698 Feb 3 '11 at 13:01
    
I never liked changing core files but whatever works for you. –  Bainternet Feb 3 '11 at 13:09

I am running 3.1 as well and have searched for days trying to find a fix with no real solution. Looks like the only option is just creating two separate menus and display them next to each other in the theme.

I currently do have a 200+ menu. I set the set_time_limit (300); and define('WP_MEMORY_LIMIT', '64M'); and it does save after about 8-10 minutes. Not really the best solution. I also tried to modify the nav-menu.php file as stated above, but the directions were of no help, may be only a solution for WP 3.0...

Anyway, if anybody finds a solution that works better than this, please let me know!

share|improve this answer

i found that if you disable the pages, posts and taxonomy meta-boxes from loading in wp-admin/includes/nav_menu.php this works - as they eat up the memory because all the content of the posts is included in the source code

add // to the beginning of lines 374 & 375 (WP3.0) to disable

//wp_nav_menu_post_type_meta_boxes();
//wp_nav_menu_taxonomy_meta_boxes();
share|improve this answer

I was having the same problem and the memory limit setting didn't do anything even when set to 150M. I also tried the changes to nav-menu.php but the line numbers don't match, maybe because I am running WP 3.1 now.

The warning I was getting was a maximum time limit error for script execution so I thought maybe it isn't a memory issue.

So instead I set in wp-config.php:

set_time_limit( 60 );

This seemed to fix the problem. It still takes ages for the menu to save though so I think there I think the code could be optimised so that you don't have to use the time limit setting.

share|improve this answer

I had the exact same problem using Chrome - I logged out and went in via Firefox - boom working again!

Hopefully that fixes things for others? Let me know I'd love to know if that was the issue!

share|improve this answer
2  
This is (like the rest of the answers to this question) in the best case a guess and not an answer that provides an explanation. –  kaiser Nov 17 at 2:38

I had same problem but nothing from here "exactly" didn't work but all together was helpful and I manage to find solution.

First step: I set the time limit to 120 (set_time_limit (120);) in wp-config.php. Second step: I track and delete all lines that contains "menu_data['description']", "menu-item-description" or "menu_item->description" in wp-includes/nav-menu.php file.

Few last versions of wp have different nav-menu.php so I think that is better to explain this method than just wrote lines that you need to erase because many others with same problem may be confused.

It still takes time but it works. I don't know what is maximum number of menu items that you can have when you this, I have about 110 menu items and it works.

share|improve this answer
2  
Modifying core files is usually extremely bad idea. –  Rarst Aug 14 '11 at 11:41

protected by kaiser Nov 17 at 2:39

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.