Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have setup a custom post type with the slug "interview" and it is working fine. I am trying to change the slug to "magazine/interview" but I keep getting 404 errors when I try to access the posts that are already there. Is there any specific trick to set a slug with "/" characters in it?

share|improve this question
1  
how are you registering your post type? have you tried visiting the permalinks settings page in admin to flush the rewrite rules? –  Milo Jan 14 '13 at 20:16
    
Oh shit! I can't believe that was the issue!! I thought I was missing something much more advanced. Thanks a lot Milo –  tzam Jan 14 '13 at 20:26
add comment

2 Answers

up vote 2 down vote accepted

Make sure to flush rewrite rules after changing the permalink structure, this can be done by visiting the Settings > Permalinks page in admin.

share|improve this answer
add comment

I don't think there is any way to use "/" in slug. I have Another solution for you. Create custom post type with slug "magazine" and create category "interview" now you have desired url "magazine/interview".

share|improve this answer
1  
you absolutely can have a / in the slug –  Milo Jan 14 '13 at 20:27
    
Milos is right. It worked fine after flushing the permalinks by re-saving the permalink settings. –  tzam Jan 14 '13 at 20:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.