Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

As of upgrading to wp 3.5 the get_avatar function started not pulling in my default backup image. This has worked for many years this way and curious to why it would stop. I am using the normal use of the function as this:

the $url value is the correct path to my default image found in my images folder in my theme. echo get_avatar($author->user_email, $size = '50', $url);

I did a little digging into the image that was being put there that is "missing" and it looks like the url is using an image server on the wp.com domain (guessing somehting like akamai). Not sure why though since i have the image local and dont want to use this as the image hosting location.

image URL starts with: http://i1.wp.com/

I looked at the source code function in the pluggable.php file. Maybe it is something to do with the gravatar return? Maybe they are changing the image location to be on the server?

Any idea what is going on here? I see there are functions that can change the way that it works to exclude gravatar but would rather still have that functionality if i can.

Thanks

share|improve this question
    
Disable all plugins and switch to TwentyEleven. Does it still happen? –  toscho Jan 11 '13 at 14:59
    
No plugins used. When i switch to TwentyEleven or TwentyTwelve it shows a the MysteryMan image and the gravatar image (which i know was working and is set at gravatar.com) is not showing up. Very strange.. –  estern23 Jan 11 '13 at 15:26
    
I think that i resolved the issue and marked the possible solution below. –  estern23 Jan 11 '13 at 15:42
add comment

closed as too localized by Chip Bennett, toscho Jan 11 '13 at 17:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

I think that i figured it out.

Gravatar default images need to be on a public url and not one blocked by htaccess. So i had this on my dev server and when i removed my htaccess file that was blocking access the images started to work. This seems to still be a new feature. Hope that this helps out someone in the future.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.