WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to upload images in WP 3.5 to set featured images for posts. Unfortunately I get the following error message:

An error occurred in the upload. Please try again later.

The installed theme is Minimatica. I've tried Googling the issue, but couldn't find any solution except downgrade to WP 3.4.2.

share|improve this question
Also, if someone knows how to get a detailed log about this error, please let me know. – Ido Schacham Jan 9 '13 at 15:05
debugging information. If you have access to server logs that would be quite helpful. – s_ha_dum Jan 9 '13 at 15:07
It's a shared hosting account, I doubt I have access to the logs. – Ido Schacham Jan 9 '13 at 15:17
You can enable the debugging though. – s_ha_dum Jan 9 '13 at 15:23
With WP_DEBUG turned on you'll have errors and notices printed on the front end. You may not have access to the logs, but you can always tell it to log somewhere you do have access to via htaccess/wp-config.php – Tom J Nowell Jan 9 '13 at 15:35

This was addressed on the Minimatica website:


You will need to update your functions.php file as follows:

In functions.php find this line (line 225 if you haven’t altered the file):

add_action('init', 'minimatica_register_styles');    

and replace it with --

add_action('wp_enqueue_scripts', 'minimatica_register_styles');


Then find this line (line 437 if you haven’t altered the file):

add_filter( 'ext2type', 'minimatica_mime_types' );

which you will replace with --

add_filter( 'ext2type', 'minimatica_file_types' );

After making the necessary changes, save your functions.php file. If you altered the file offline, upload the saved functions.php file to the wp-content>>themes>>minimatica theme folder. Refresh your new post screen and you should be good to go. This worked perfectly for me so hopefully will for you as well.

share|improve this answer

I had this problem too.

Try to add this code to your wp-config.php file, just before the require_once(ABSPATH . 'wp-settings.php'); string.

define('CONCATENATE_SCRIPTS', false );
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.