Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm trying to establish a blog with NGINX and PHP-FPM.

I wonder if my version of PHP should work with WordPress

/usr/bin/php-cgi -v
PHP Warning:  PHP Startup: magickwand: Unable to initialize module
PHP 5.2.17 (cgi-fcgi) (built: Sep 17 2012 00:15:25)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
    with eAccelerator v0.9.6.1, Copyright (c) 2004-2010 eAccelerator, by eAccelerator`
share|improve this question
    
Have WP blog turned on. So it works with my actual version of PHP-fpm reported 0.6 by phpinfo –  Yurij73 Jan 8 '13 at 14:34

1 Answer 1

up vote 1 down vote accepted

According to the official system requirements, PHP version 5.2.4 or greater should work. However, some plugins and / or themes may require PHP version 5.3, though. BTW, PHP 5.2 has reached its End of Life a couple of year back (in 2011).

share|improve this answer
    
to be more clear on question: i have php 5.24 and it works perfectly with WP 3.5 but i changed for nginx and added a PHP-fpm.rpm to maintain server request. Then my question is about this mentioned PHP-fpm. –  Yurij73 Jan 8 '13 at 9:28
    
Php-fpm is process manager available as part of php. So, when it comes to versions, PHP = php-fpm. –  Pothi Jan 8 '13 at 13:41
    
No, as phpinfo(); in section cgi-fcgi tell me that i have php-fpm active and php-fpm version 0.6. If i look at the top of phpinfo page there is info about php version that is 5.2.... –  Yurij73 Jan 8 '13 at 14:25
    
In fact i just started the WP3.5 on my nginx+fpm by fixin rightway rewriterules for site.conf. so the question still for amazing part –  Yurij73 Jan 8 '13 at 14:27
    
According to the official php-fpm page, php-fpm 0.6.x is the latest version. So, that should work just fine with WP. –  Pothi Jan 8 '13 at 15:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.