Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Iv got this code in my blog.php:

<?php wp_get_archives( array( 'type' => 'monthly', 'limit' => 12 ) ); ?>

It links to:

/2013/01

My page only loads the header and footer - I think its the main loop - what do I have to do, do I need another file?
Or say where to output the code?

Thanks..

share|improve this question
    
There is not enough information here to help. In what way does the page not load? Redirect? Blank page? What? Is there a public URL that you can provide? –  s_ha_dum Jan 4 '13 at 15:14
    
I got that code in blog.php its my "page of posts" file, when I click on januari 2013 i got a page with only my header and footer –  user24828 Jan 7 '13 at 10:54
    
Do you have any posts that were created in January 2013? –  totels Jan 7 '13 at 12:23
    
yes: 7 januari 2013 @ 15:10 this is my website: finsens.salescaredev.nl/-expat-services/newsletter –  user24828 Jan 7 '13 at 13:38
    
Ok this really really sucked I had my function in my archives.php but it needs to be in archive.php so I removed 1 character and it worked! –  user24828 Jan 7 '13 at 13:55
add comment

1 Answer

up vote 1 down vote accepted

The date.php, archive.php, and index.php files control the date archive output. You need to check the contents of those files, in respective order, to find the problem.

If WordPress can't find date.php, it will check for archive.php, and load that if found. Otherwise, index.php will be used to display date archives.

See my answer on a previous question for more information

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.