Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am having this weird issue wherein if I create and publish a post, I can/am attributed as the author. However, if my editor creates a post and tries to add me as an author, I don't appear. It doesn't work even if I go in after she's done editing and try to make myself author. I still don't appear in the dropdown.

Any idea about what may be the issue here? Can I provided more info/screenshots?

share|improve this question
    
To what User Role is your username assigned: Administrator, Editor, or Author? –  Chip Bennett Dec 21 '12 at 17:48
    
Admin is the role assigned to my profile. –  Jeff Gaudette Dec 21 '12 at 21:39
    
Is your editor an Editor? –  sam Nov 21 '13 at 20:00

3 Answers 3

Have you tried using an external tool to post and make the changes? Windows Live Writer is quite simple and easy to use. Using this you can change any post's author and other meta content.

share|improve this answer
    
I haven't tried this, but obviously this an issue with wordpress because I should be able to change myself to the author. –  Jeff Gaudette Dec 21 '12 at 21:39

I guess you need administrator permissions to change the authors or modify the user role permissions.

WordPress allows changing the post author only to a super-admin or a user with the right to edit others posts.

Also, an editor only has these permissions

share|improve this answer
    
Right, but as the super admin, I still can't go back and change myself to the author. Let's say I write a post and assign author to "John". I save post. Now I go back and want to change author to me. I am not available as an author. However, if I write the article and don't select an author, I am assigned the author. –  Jeff Gaudette Dec 21 '12 at 21:37

Permissions can be tricky, and if not set and unset correctly can end up with strange bugs; take a look at your database entry for $prefix_user_roles in the $prefix_options table. The data there will be a serialized array; copy the string to a php file somewhere and unserialize it to see if it makes any sense. You should make sure that the 'edit_others_posts' capability is listed under the 'administrator' array.

If it isn't, use php to add it to an array and then reserialize it before you put it back in the database. Just straight editing the serialized string can cause some really bad things.

Also, test all of your plugins. Deactivate them and activate them one at a time to see if one could be your problem. You might want to do this before you change the value in the database, because some plugins will edit that value on (de-)activation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.