Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have Wordpress 3.5 installed on IIS7 and I'm using SQL Server instead of MySql. Some strange "glitches" occur and I think their related to the same problem.

  1. I cannot see media library items on the first page. If I'll go to ~/upload.php?paged=2 I am able to see all the media. It basically starts to show the items from the second page.
  2. The same problem occurs with the posts list. If I'm going to another page in the posts category, I am able to see them.
  3. Settings/Permalinks throws and internal server error, so I can't check what's there even if I'm not sure if I would be able to change permalinks from there.

Any ideas are appreciated, I'm curious what's the reason for the first two points.

Update: for point 3, the detailed error sounds like this:

C:\Program Files\PHP\v5.3\php-cgi.exe - The FastCGI process exited unexpectedly
Handler PHP53_via_FastCGI
Error Code  0x00000001
share|improve this question
1  
What are the logs saying about point 3? –  Mike Madern Dec 20 '12 at 10:52
    
+1 Or simply turn the full debugging env on and tell us about the output. –  kaiser Dec 20 '12 at 10:53
    
i updated my question –  Marius Balaban Dec 20 '12 at 11:02
    
Corresponding to your error message. Check folders permision. Check if correct php.ini loads. Check location of the extension dir, it should be the same as you have in php.ini. –  Maxim Orlovsky Dec 20 '12 at 11:14
    
Without the correct php.ini and the correct path for the extentions dir I wouldn't be able to access the dashboard at all. –  Marius Balaban Dec 20 '12 at 11:23

1 Answer 1

To correct work of permalinks on IIS you should install http://www.iis.net/downloads/microsoft/url-rewrite

Also take a look on complete guide http://www.iis.net/learn/application-frameworks/install-and-configure-php-applications-on-iis/install-wordpress-on-iis

share|improve this answer
    
I installed it following that guide and I have url rewrite installed. –  Marius Balaban Dec 20 '12 at 11:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.