Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a site at http://iqonline.eu which uses w3 total cache for all its caching and minifying purposes and everything is working nicely as per normal. However when checking the site on Google page speed it still says that leverage browser caching isn't being used and to extend the freshness time of certain media items.

I have the following settings in the browser cache section, but regardless of the settings, it doesn't seem to affect the google page speed results?

I am using a windows 2008 VPS server ( I know, I know...) is there anything i'm missing?

screenshot of settings

share|improve this question

closed as off-topic by mrwweb, Johannes Pille, birgire, ialocin, Pieter Goosen Aug 30 at 4:06

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Your question should be specific to WordPress. Generic PHP/JS/HTML/CSS questions might be better asked at Stack Overflow or another appropriate site of the Stack Exchange network. Third party plugins and themes are off topic." – mrwweb, Johannes Pille, birgire, ialocin, Pieter Goosen
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

Since you're using a Windows 2008 VPS I assume WordPress has been installed on IIS. The answer by Pontus is helpful for Apache WP installs. You will need to convert the Apache code to what IIS can understand since IIS does not make use of .htacess rules.

I have not tried this yet but a simple way to do it might be to go into IIS, navigate to your Site and click on "Output Caching". You should be add caching rules based on extension there.

share|improve this answer

I recommend you to read this article W3 Total Cache -Plugin: The Complete Settings Guide, it's a great tutorial to manually setup your w3tc.

And when you saving your settings remember to flush your cache because if you don't Google Pagespeed will test it on the old cached files..

You can try to add this .htaccess rules:

## EXPIRES CACHING ##
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access 1 year"
ExpiresByType image/jpeg "access 1 year"
ExpiresByType image/gif "access 1 year"
ExpiresByType image/png "access 1 year"
ExpiresByType text/css "access 1 month"
ExpiresByType application/pdf "access 1 month"
ExpiresByType text/x-javascript "access 1 month"
ExpiresByType application/x-shockwave-flash "access 1 month"
ExpiresByType image/x-icon "access 1 year"
ExpiresDefault "access 2 days"
</IfModule>
## EXPIRES CACHING ##

This will sett expire-headers on your content.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.