Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I had 'theshortfilm.co" before changing to my current url 'welovefilm.co'. I changed my address 6 months back, everything went fine. But now when I activated my networks, I get my old url in the code. Please see the image below.

http://imgur.com/PW6oW

But when I change the url manually to new address and add it to the wp-config file, I get an error saying website is on infinite redirect loop.

Please help me fix this issue.

Thank You.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

I'm not sure what exactly is the problem that you're having but hopefully this solution will work.

  1. Backup your database (This is very important)
  2. Download this script: http://interconnectit.com/products/search-and-replace-for-wordpress-databases/
  3. Use it to replace the old url "theshortfilm.co" to the newer one "welovefilm.co"
  4. Remove all the url-related configurations you did in your "wp-config.php"
  5. Go to admin panel to the same "enabling the network page" & this time you'll see your new url inside the configuration. Copy this new configuration & put it in .htaccess & wp-config.php replacing the previous one (if any)
    6) Test to see if your site works, if it does, congrats. If it doesn't, use the backup you took in step one to undo anything you did just now & then try someone else's answer.

Note: All this script does is search for a string in the database and replace it with another. You need to be extremely careful when using it. If it says "modified 0 rows", then you most likely put in the wrong url. For best results, include the http://.

That file gives database access to anyone who can view it, so don't use it on production server & immediately delete it after use

share|improve this answer
    
That worked! Thanks a lot for the help. –  Jijo Jose Dec 15 '12 at 12:18
add comment

I think the thing is not such complex as you made it. I think no such coding is needed. To make a try, revert the codes you altered as it was before. Then, get into the admin panel /wp-admin.

In Settings > General tab change the WordPress address (URL) and Site Address (URL) to your desired one.

And then check whether it's ok or not.

share|improve this answer
    
I think my question was not clear. URL changing was successful and this was 6 months back. But now when trying to activate multisite, wordpress is giving me the old url. So when I add the code given to the config file site forwards me to 'theshortfilm.co'. Does this have something to do with database of server? –  Jijo Jose Dec 15 '12 at 7:18
    
Have you checked you .htaccess configurations? –  Mayeenul Islam Dec 15 '12 at 7:28
    
Thanks for the reply. The Problem is solved. :) –  Jijo Jose Dec 15 '12 at 15:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.