Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I support a WordPress 3.4.2 site, lifering.org, running on a GoDaddy Virtual Server. Recently I chose to upgrade the underlying O/S from CentOS 5 to CentOS 6. The rebuild was entirely automated and I don't know what it involved. I restored my site from backup, and since then the plugin WP-DBManager no longer backs up our MySQL database because it says it can't find the mysql path. The mysql path is /usr/bin/mysql, same as it always was, but for some reason the PHP utility that finds it is failing. I posted a question in the Wordpress support forum for the plugin several weeks ago and have no reply; the original supporter has a blog post that says, basically, I have a real job now, goodbye.

After much research I think I may have a problem with PHP safe mode, but I don't know enough about it to evaluate. My PHP version is 5.3.3-14.el6_3. My php.ini contains these entries, in this order but not all together:

safe_mode_allowed_env_vars = PHP_
safe_mode_protected_env_vars = LD_LIBRARY_PATH
safe_mode_exec_dir = 
safe_mode_include_dir = 
safe_mode = off
safe_mode_gid = off

These must have been set during the rebuild. Reading the PHP manual, I think if I set safe_mode_gid = on it may solve my problem, but: if safe_mode = off why do I have a problem at all? I have no way of knowing what the compilation switches were. Can anyone suggest anything, including an alternative plugin? As far as I can tell there is NO other plugin that does what this does.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I solved this with help from the main StackOverflow site. One of the commenters suggested that the open_basedir directive might be set in php.ini - and that was the issue. Here is the open_basedir setting:

open_basedir = "/var/www/vhosts/lifering.org/:/tmp/"

I created a hard link mysql (could have been a symlink) to /usr/bin/mysql in the /tmp directory and then changed the MySQL path statement in WP-DBManager to read /tmp/mysql. The error message cleared immediately.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.