Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm at version 3.0 and want to move to 3.0.1 without having to download/unzip/delete/upload but I get this error when trying to update:

Could not create directory.: /public/wp-content/upgrade/wordpress-3.tmp/wordpress

Is is safe to chmod 777 the upgrade folder?

share|improve this question
    
If you change the permissions and run, does everything work properly then? –  artlung Aug 11 '10 at 20:54

1 Answer 1

up vote 3 down vote accepted

It should be relatively safe to chmod it to 777 for as long as you need to in order to upgrade, and then change back to what it was before. Generally speaking, 755 is the recommended directory permission.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.