Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have been adding at the top of my wp-config.php the following to switch off php logger but won't take any effect on it. Is there something else what I should do?

error_reporting(0);
@ini_set(‘display_errors’, 0);
share|improve this question
    
Check if you have WP_DEBUG to false in wp-config.php. –  M-R Dec 12 '12 at 14:45
    
Your single quotes are no single quotes. Use ' instead... –  kaiser Dec 12 '12 at 15:20
    
Yes I know. However in my code I have been using the single quotes. –  kakuki Dec 12 '12 at 15:31

1 Answer 1

Also in wp-config.php, set the WP_DEBUG_DISPLAY constant to FALSE.

Snippet from wp-includes/default-constants.php:

// Add define('WP_DEBUG_DISPLAY', null); to wp-config.php use the globally configured setting for
// display_errors and not force errors to be displayed. Use false to force display_errors off.
if ( !defined('WP_DEBUG_DISPLAY') )
    define( 'WP_DEBUG_DISPLAY', true );
share|improve this answer
    
tried it seems like thesis won't pick this setups from wp-config –  kakuki Dec 12 '12 at 15:03
    
Do you observe this issue only in Thesis, or can you reproduce it when using, for example, Twenty Twelve or Twenty Eleven? –  Chip Bennett Dec 12 '12 at 15:05
    
yes it seems like I have been changing the template and over there is working so I'm going to post this by thesis. Thanks for the feedbacks –  kakuki Dec 12 '12 at 15:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.