Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have just upgraded Wordpress to the latest version (3.5) and it's now throwing me a Javascript error when I try to add a media :

_.omit is not function

Please, any help would be really appreciated

share|improve this question
    
Re-upload all files, disable all plugins and switch to TwentyEleven. Does it still happen? –  toscho Dec 11 '12 at 23:02
add comment

2 Answers

Okay I found the issue. It was a problem with my "Nexus" theme.

For anyone with the same issue, I commented out the line "wp_enqueue_script('jquery-prime-options'..." in this function : "option_tree_load"

share|improve this answer
add comment

the solution that worked for me is this:

Open wp-content/themes/nexus/prime/classes/class.admin.php and comment out the line 308:

$po_admin->option_tree_load(); 

This seems to have fixed an issue with the “insert media” button not working upon upgrade to WP 3.5

more details here: word-press nexus support

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.