WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 81 bytes) in /home/public_html/hol/wp-includes/meta.php on line 571

I'm receiving this error when I try to log into my wordpress blog as admin. If I login anything else lower than level 3 everything works fine!

I tried removing all custom functions.php, error remains. But I don't understand why meta.php? what is there on line 571?

What do I do to diagnose the bad code? btw, I removed db and went back with same php files to db of 1 week ago and all works fine. So there must be something in DB? but what??

I have 256mb allocated in php.ini, should be mooore than enough!


As advised I tried to test out every plugin and theme for memory usage.

First thing I did, is to reinstall wordpress on my test server, turn on custom theme and all plugins...

Max I got was 50mb.

enter image description here

I reimported DB from 1 week ago.

And memory usage was double, but still not bad.

enter image description here

At this point, I reimported current DB and memory error re-emerged.

At this point I disabled all plugins and enabled 1 by 1. When I reached sendpress plugin error came back!

But sendpress is a simple plugin, all it does is collect emails and create a list of emails. It was not giving errors 1 week ago (have this plugin installed for about 2 month had no issues before)

So my question now is, what is happening? why would sendpress cause issues?

share|improve this question
Did you try searching the site for related questions before posting? – Chip Bennett Dec 6 '12 at 13:01
possible duplicate of Allowed memory size exhausted. WordPress side solution – Chip Bennett Dec 6 '12 at 13:03
@ChipBennett I have 256mb allocated, how is that not enough? I did extensive search here and on stack. – Sandro Dzneladze Dec 6 '12 at 13:32
"So my question now is, what is happening? why would sendpress cause issues?" - This question is likely too localized for WPSE, and you would be more effective asking the Plugin developer directly. – Chip Bennett Dec 6 '12 at 16:18
up vote 2 down vote accepted

Turn off all plugins. Switch to TwentyTen. Then install the debug bar and helpers. Then switch back to custom theme - reload. Turn one plugin on - reload, next plugin - reload, etc.

share|improve this answer
I did exactly this, please take a look at my updated OQ. – Sandro Dzneladze Dec 6 '12 at 12:30
@SandroDzneladze This is in idle mode... – kaiser Dec 6 '12 at 17:17

Meta.php have nothing to do with that. It is probably a plugin or your theme that cause that. Try to disable all plugins by renaming the directories and if you can login once all the plugins are disabled try to activate them one by one.

share|improve this answer
Please check my edit. – Sandro Dzneladze Dec 6 '12 at 12:48
With the out of memory kind of error you get the report on the file/plugin which crossed the boundry, but it is totally possible that you have reached full memory before that and the error is being triggered because of a relatively small allocation that the last plugin has done. What you need to do is how much memory each plugin added after its activation. BTW, just because the plugin is simple it doesn't mean it doesn't consume alot of memory, maybe your email table is very big and it retrieves all of it from the DB every time you login. – Mark Kaplun Dec 6 '12 at 14:11
Well, sendpress was using 200mb, after disabling it memory usage went back to normal 60mb. So it is 100% that plugin fault! I didn't have many emails, I also did a simple check, I removed all tables of this plugin, but it didn't bring back consumption. There is something terribly wrong with it. – Sandro Dzneladze Dec 6 '12 at 15:12

I got the same error message after a plugin update for my [directory] website 1 Asked the hosting company to increase the allowed size but didn't work. Uninstalled all plugins and reinstall one by one and here goes the bingo.

share|improve this answer
Sorry, is this an answer? If so, please elaborate. – s_ha_dum Apr 23 '15 at 16:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.