WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm creating custom post types with Magic Fields v2.0.1 and i use the qTranslate v2.5.32 plugin for a second language on Wordpress 3.4.2.

The problem is that on Magic Fields in the settings of the custom post type when i select to support only "Title" (and not "Editor") there is no extra Post tile field for the translation in the Custom Post Type write panel. If the "Editor" in the settings is on, there are 2 fields for the post title for each language as normally. Is there a way to hide the default visual editor but keep the title field with the translation. I want just the English and second language Title fields. I tried to hide it with the Adminimize plugin but it seems that Magic fields overrides it. Also i tried to hide the visual editor from the general settings of the Magic Fields but still the options in the Custom Post type settings override that.

Also there are no translation fields for custom taxonomies.

Has anyone run on this? Any work around?! Please help!

share|improve this question

closed as off-topic by Pieter Goosen, birgire, gmazzap, Johannes Pille, s_ha_dum Oct 3 '14 at 16:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Your question should be specific to WordPress. Generic PHP/JS/HTML/CSS questions might be better asked at Stack Overflow or another appropriate site of the Stack Exchange network. Third party plugins and themes are off topic." – Pieter Goosen, birgire, gmazzap, Johannes Pille, s_ha_dum
If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 0 down vote accepted

I solved the problem by checking the option Editor on the Magic fields post type settings and hiding the visual editor with an extra option on Adminimize settings targeting the Visual Editor with it's ID on the specific post type. So now qTranslate can see the Title and apply the second language while the visual editor gets hidden from the user.Worked like a charm!

share|improve this answer

This needs a custom work to integrate these two plugins.

Right now, they are incompatible. =/

share|improve this answer
Thanks Gnuget for the notice. I managed to solve it with an extra option on the adminimize settings for the custom post type of the magic fields. – drivebass Dec 7 '12 at 8:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.