Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

We decided to not use the .html on pages http://wordpress.org/extend/plugins/html-on-pages/ because its not supported already.

This plugin puts an .html extension to all the pages. But after deactivating it, the URL's are not redirecting to the proper page.

Need help? Any idea why this is happening?

share|improve this question

1 Answer 1

That plugin was last updated 2008-11-20 and it's doubtful it will work with a new version of Wordpress and correctly revert URLs or changes it makes. Try resetting permalinks in Dashboard>>Settings>>Permalinks.

And, because your question is very specific to that plugin, you're much better off asking in the wordpress.org forums tagged for that plugin: http://wordpress.org/support/plugin/html-on-pages

share|improve this answer
    
Thanks songdogtech. I doubt if someone will answer me in that support page. Anyway, what I am planning to do is just remove the suffix on the requested url. –  user20493 Nov 26 '12 at 4:04
    
The GUID shouldn't be used for generating URLs so even if the suffix is there is shouldn't matter and is best left alone. –  s_ha_dum Nov 26 '12 at 5:01
    
s_ha_dum, you're right; I deleted reference to GUIDs in the database. –  songdogtech Nov 26 '12 at 5:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.