Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am working on this web . I need to fiugure it out on how to avoid repeating the URL in the home Page.

The Home page has actually two url

creativesquaresummercamp.com/

creativesquaresummercamp.com/welcome-to-your-best-summer/

I want my Home page just having this url

creativesquaresummercamp.com

This is happening of course because this specific page has been selected page as Home Page. The permalink of this page obviously is: creativesquaresummercamp.com/welcome-to-your-best-summer/

How can i figure it out this issue?

Thanks

share|improve this question
    
What are your settings under Dashboard -> Settings -> Reading. Specifically, what are your Front Page Displays, front page, and posts page settings? –  Chip Bennett Nov 23 '12 at 12:50
    
exactly this is the point, the client has used a Theme called Choice and in the Theme Frontpage Settings there is this page selected :"Welcome to your best Summer". In the menu bar drop down with the option i can choose whatever page i want. –  Manna Nov 23 '12 at 13:08
add comment

2 Answers

up vote 1 down vote accepted

From the comments:

What are your settings under Dashboard -> Settings -> Reading. Specifically, what are your Front Page Displays, front page, and posts page settings?

And your reply:

exactly this is the point, the client has used a Theme called Choice and in the Theme Frontpage Settings there is this page selected :"Welcome to your best Summer". In the menu bar drop down with the option i can choose whatever page i want.

This is the problem.

WordPress provides settings for using a static page as the site front page. Use them, instead of custom Theme options for the same purpose. If the core WordPress Front Page settings are used, WordPress will automatically redirect the static page permalink to the site front page.

So, to fix:

  1. Go to Dashboard -> Settings -> Reading
  2. Set Front Page Displays to a static page
  3. Set the page on front setting to Welcome to Your Best Summer
  4. If you need a blog posts index, choose a static page to display it, via page for posts
  5. Then, most importantly, if the custom Theme option interferes with the core handling of the Site Front Page, you may need to clear out that custom Theme option.
share|improve this answer
    
great, this is the solution! –  Manna Nov 23 '12 at 13:19
add comment

You can solve this by redirecting the static page to your site´s root. This will also prevent duplicate content issues in search engines.

Add something like this to your .htaccess file:

# Redirect static homepage to root
Redirect 301 /welcome-to-your-best-summer/ http://www.creativesquaresummercamp.com/
share|improve this answer
    
Thanks, unfortunately i do not have the access to the .htaccess file to test it. You know if it's possible to work around this in a other way? –  Manna Nov 23 '12 at 12:27
    
When properly implementing a static page as Site Front Page, there is no need to do this, as WordPress automatically handles the redirect from page_on_front permalink to home_url(). –  Chip Bennett Nov 23 '12 at 13:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.