Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a blog page where blog posts have an excerpt on with a continue reading link below.

When the link is clicked the full post should appear/or should be diverted to.

This isn't that case. The user is diverted to the post, however only the excerpt is displayed along with a continue reading link which doesn't activate anything.

I have deactivated all plugins, I have also played around with the settings but can't find any triggers.

Blog Page - http://vikingsandc.co.uk/strength-and-conditioning-blog/ Post Page - http://vikingsandc.co.uk/2012/11/test-text-test-text/

share|improve this question
    
does that also happen with an unedited version of your theme? –  Michael Nov 22 '12 at 17:17
add comment

1 Answer

up vote 3 down vote accepted

You need to use the_content instead of the_excerpt when you display your 'single' post.

If you would post your code, you might get a more detailed answer.

share|improve this answer
    
Which .PHP file (line estimate would help) can I find the part of the code you need in? –  Graeme Hutchison Nov 22 '12 at 17:14
    
That depends on the theme. (If your theme where using body_class I could tell by looking.) If you have a single.php, chances are that that is it. Otherwise, you probably need to write a switch into index.php, but it possible that those files are using get_template_part or some other means to include the formatting source from still other files. –  s_ha_dum Nov 22 '12 at 17:18
    
found it... sorry I hadn't realised you told me the location (single post) found the criminal and changed it over as suggested. Thank you for the quick response –  Graeme Hutchison Nov 22 '12 at 17:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.