Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm running 3.4.2 on Ubuntu. I'm unable to make any changes to menus at all. Also I'm unable to upload anything (flash or browser uploader) to the media library. However plugins have no problem adding things to the library. When I try to make a change I get page not found.

I have my memory limit set at 128MB in php.ini and wp-config.php. I've done all the basic troubleshooting on the wordpress wiki. Disabled all my plugins, switched themes, even ran aptitude reinstall wordpress just to make sure all the core files weren't damaged.

This is my debug.log

[21-Nov-2012 02:37:53 UTC] PHP Notice:  wp_enqueue_script was called <strong>incorrectly</strong>. Scripts and styles should not be registered or enqueued until the <code>wp_enqueue_scripts</code>, <code>admin_enqueue_scripts</code>, or <code>init</code> hooks. Please see <a href="http://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 3.3.) in /usr/share/wordpress/wp-includes/functions.php on line 2758
[21-Nov-2012 02:37:53 UTC] PHP Notice:  wp_enqueue_style was called <strong>incorrectly</strong>. Scripts and styles should not be registered or enqueued until the <code>wp_enqueue_scripts</code>, <code>admin_enqueue_scripts</code>, or <code>init</code> hooks. Please see <a href="http://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 3.3.) in /usr/share/wordpress/wp-includes/functions.php on line 2758
[21-Nov-2012 02:37:54 UTC] PHP Warning:  Creating default object from empty value in /usr/share/wordpress/wp-admin/includes/update.php on line 92

I'm managed to stump my self here. I've done everything short of re-installing the entire site.

share|improve this question
    
What happens if you set the PHP memory limit to 256M instead of 128M? –  Chip Bennett Nov 21 '12 at 3:14
    
HOLY CRAP THAT WORKED!? Thank you Chip! –  Hugh Nov 21 '12 at 6:17
    
Oh, well great! I've just added that as an answer, then; with some additional information. –  Chip Bennett Nov 21 '12 at 12:20
add comment

2 Answers

I have my memory limit set at 128MB in php.ini and wp-config.php. There is an implicit minimum requirement for the WP Admin to be able to use 256M.

Try setting your PHP memory limit to 256M instead of 128M.

Also, be sure you have WP_DEBUG set to true in wp-config.php:

define( 'WP_DEBUG', true );

Which will likely reveal an exhausted-memory fatal error.

share|improve this answer
add comment

backup your wp-config.php, delete the original and run your yoursite/wp-admin again, filling all the fields back.... hope it works. if not, wich theme are you using?

share|improve this answer
    
Explain why that could solve the problem. –  toscho Nov 21 '12 at 5:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.