Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

A clean install of Wordpress 3.4.2 is giving a blank screen when logging into the admin panel. This is due to the following resources not loading in Chrome:

GET /wp-admin/  /wp-admin/:32
GET /wp-admin/load-styles.php?c=0&dir=ltr&load=wp-jquery-ui-dialog&ver=3.4.2  /wp-admin/:32
GET /wp-admin/load-scripts.php?c=0&load=jquery,utils&ver=3.4.2  /wp-admin/:32
GET /wp-admin/load-styles.php?c=0&dir=ltr&load=admin-bar,wp-admin&ver=3.4.2  /wp-admin/:26
GET /wp-admin/load-scripts.php?c=0&load=admin-bar,hoverIntent,common,jquery-color,wp-ajax-response,wp-lists,quicktags,jquery-query,admin-comments,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,dashboard,thickbox,plugin-install,media-upload,word-count,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-button,jquery-ui-position,jquery-ui-dialog,wpdialogs,wplink,wpdialogs-popup&ver=3.4.2  /wp-admin/:32

However, visiting these links directly returns the contents as normal.

There are no entries in Apache's error log for this.

I have found that if I add the following line just before echo $out; in wp-admin/load-scripts.php and load-styles.php, the page loads the assets correctly, aside from TinyMCE:

header('Content-Length: ' . strlen($out));

Similarly, if I add the following line to my wp-config.php the admin panel loads correctly (as it bypasses load-X.php):

define('CONCATENATE_SCRIPTS', false);

Content does display correctly in Firefox however.

Is this a bug? If so, is the issue already known?


The only oddities about my setup are that I am running PHP version 5.4.8-1~precise+1, obtained from Ondřej's PPA, on Apache/2.2.22 (on Ubuntu).

The most common suggestion seems to be that it is a problem with my configuration, rather than Wordpress - my Apache install is fairly standard, the VirtualHost for this blog configured as so:

<VirtualHost *:80>
    ServerName example.com

    DocumentRoot /var/www/wordpress
    <Directory /var/www/wordpress>
        Order allow,deny
        allow from all
        Options -Indexes +FollowSymLinks
    </Directory>

    ErrorLog /var/log/www/wordpress/error.log
    LogLevel warn
    CustomLog /var/log/www/wordpress/access.log combined
</VirtualHost>

The Wordpress install has no extra themes, plugins and whatnot. It is a simple download from Wordpress.org that has been configured using the installer.

share|improve this question
1  
You usually need AllowOveride All if it isn't configured globally. I don't know if that is your problem. Does PHP's file_get_contents work in other contexts on your server? –  s_ha_dum Nov 17 '12 at 14:36
1  
'There are no entries in Apache's error log for this.' What entries are in the log? Any entry is relevant at this point. –  Stephen Nov 17 '12 at 14:42
1  
Please improve your error output like I show in this Gist. Then report back with the shown errors. –  kaiser Nov 17 '12 at 14:57
    
@s_ha_dum I've added that but don't see any effect. There aren't actually any .htaccess files in the installed download - should there be? –  Ross Nov 17 '12 at 19:16
    
@Stephen The only entries in the error log are for a missing favicon. –  Ross Nov 17 '12 at 19:19
show 2 more comments

closed as too localized by Rarst Jun 8 '13 at 20:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

I believe I've found a root to the problem. I recently upgraded PHP from apt and unbeknownst to me it now uses apache2filter rather than apache2.

Not entirely sure what triggered that, but it's not how I set it up. Switching over to nginx for example works fine (it also fixes an issue with xmlrpc.php not loading) - so the problem is with apache2filter's default configuration. Sorry for a bogus question!

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.