Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

We developed the wordpress site here:

wwww.kirschfamilycomputerservices.com/sam/wheresthefairness

^^ URL does not exist now.

When the website was done, we transferred the database & theme over to a new host.

The issue is odd and really critical. We have to present the website to the client tonight, and none of our URLs are working properly.

the index to the new host is this: http://www.advertisingagency.me/wheresthefairness/

The links just under the header to the right are called in a list in the header PHP file and look like this:

<div id="wtfloginfb">
<?php
if ( is_user_logged_in() ) {
    echo 'Welcome Back!';
} else {
    echo 'Hello! New to WTF?!';
};
?>
 <?php wp_register( ' '  , ' ' , ' ' ); ?>/
<?php wp_loginout( home_url()  ); ?> |
<a href="<?php bloginfo('template_url'); ?>/new-case">State Your Case</a>| 
<a href="<?php bloginfo('template_url'); ?>/cases">View Cases</a>

</div>

The only file outside of the theme directory that I edited while designing the site was the general-template.php file, in which I changed the Site Admin link to display as "Dashboard" and made it point to root/dashboard.

So the problem is this.. When you go to the website and hover over a link, it shows the correct path to the file in question, however, when trying to navigate to ANY page directly, we are always given this error:

Not Found

The requested URL /sam/wheresthefairness/index.php was not found on this server.

So what do you guys think the problem could be? Could it be somewhere in the WP files themselves? Or does this sound like a database error? I've honestly never encountered something like this. I've never pointed my browser to a very specific path, and had it tell me that it couldn't load the page, because it tried to go to a different path...

1/19/11-4:36pm Edit to add: We get this error whenever we try to direct link to a post or a page. So essentially, the only pages we can actually view on the new host is the index page, and wp-admin.

share|improve this question
    
did you check if mod_write is enabled on the server? –  onetrickpony Jan 19 '11 at 21:29
5  
if it is enabled, make sure the .htaccess file from the site root is writable, then go to settings > permalinks and assuming you chose the correct url structure, click save. –  onetrickpony Jan 19 '11 at 21:37
1  
IT WORKED!! You just saved our asses SOOOOOOOO hardcore. Thank you so much!! –  Lynne Jan 19 '11 at 21:41
1  
@Rarst I agree! I was going to answer the question with his solution and mark it correct, but I want him to get full credit! –  Lynne Jan 20 '11 at 18:02
1  
@One Trick Pony, you should add your comment as an answer so that Lynne accepts it and give this question closure :P –  Fernando Briano Jan 26 '11 at 13:59

2 Answers 2

up vote 1 down vote accepted

Posting as an answer from the @OneTrickPony comment above:

  1. Verify that mod_rewrite is enabled on your server.
  2. Assuming that mod_rewrite is enabled, ensure that the root WordPress install directory is WordPress-writeable, or that, if it exists, the .htaccess file in the root WordPress install directory is WordPress-writeable. (See file permission scheme for WordPress, and Hardening WordPress: File Permissions.)
  3. Then, in your WordPress admin area, go to Dashboard -> Settings -> Permalinks. Click "save" (no need to change settings), which will force a flush of the WordPress URL rewrite rules, and will rewrite the mod_rewrite rules to the .htaccess file.
share|improve this answer

As per comments functionality of pretty permalinks in WordPress has dependencies on server configuration. So it differs, depending on server used.

List of documented dependencies is available in Using Permalinks article in Codex.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.