Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have recently moved a wordpress website abc.com to xyz.com, And xyz.com functionality is good and working well.

And i have created a post with a image in it using Featured Image, and when i publish this post, its not displaying images in it. And when i check the URL of image using Inspect Element, i see the location as

http://www.abc.com/wp-content/uploads/2012/11/ACFA7.jpg instead of http://www.xyz.com/wp-content/uploads/2012/11/ACFA7.jpg .

And when i changed this to correct url.. then images are working good using inspect element.

And i have changed the permalinks and wp-options in database for siteurl to xyz.com , is there any thing more i need to configure or update into site or database anywhere.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

I believe there are some root-links that you haven't changed.

Please follow these steps

  1. Login to admin section www.xyz.com/wp-admin
  2. Navigate to settings->general-> and change the 'Site Address (URL)' and 'WordPress Address (URL)'.

Also please check the permalinks and settings->media there is an upload directory and the default wordpress location is wp-content/uploads, check if it is different for you.

share|improve this answer
1  
Now!, its working i forgot to update Setting->media and wp-content/uploads –  Rafee Nov 21 '12 at 9:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.