Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Can't figure out why this would be happening- wp install issue or .htaccess issue?

I am using a theme but the same problem occurs with the default wp themes. After I create a new page (example: about), I get a 404 when I try to access it from the navigation or when I just enter the URL: domain.com/dev/about, I am also getting 404.

WP installed in httpdocs/dev.

All plugins are deactivated. Everything else appears to be working correctly.

share|improve this question
    
i should add that this is a brand new fresh/clean WP install. no extra custom code, no content. –  user23687 Nov 15 '12 at 21:48
1  
Did you save your permalinks with a new structure other than the default(s)? Settings > Permalinks <save> –  Zach Nov 15 '12 at 21:49
    
We just switched it back to Default and now pages are loading correctly. Any ideas why changing permalinks to Post Names throws 404s? –  user23687 Nov 15 '12 at 21:53
    
do you get your server's 404 page, or a WordPress 404? –  Milo Nov 15 '12 at 22:32
    
the WordPress 404 –  user23687 Nov 15 '12 at 23:08
show 1 more comment

1 Answer

WordPress is not receiving requests, check if mod_rewrite is enabled and an .htaccess file is being generated by WordPress (assuming you are using Apache, not IIS).

See using pretty permalinks and fixing permalink problems for more info.

share|improve this answer
    
Still getting the server 404 pages and mod_rewrite is enabled and the .htaccess file is: –  user23687 Nov 28 '12 at 21:47
    
# BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress ErrorDocument 404 /404.html –  user23687 Nov 28 '12 at 21:47
    
I changed the .htaccess file to: # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase /dev/ RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /dev/index.php [L] </IfModule> # END WordPress ErrorDocument 404 /404.html –  user23687 Nov 28 '12 at 21:53
    
...because under Permalinks settings, above that code snippet it says: "If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file." I am now getting the WP theme 404, not the server 404 like before. –  user23687 Nov 28 '12 at 22:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.