Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm facing a problem, basically if I use the

tags into the html and then change to visual editor, the tags disappear, and it stays in plain text.

Scenario:

  • In HTML mode, I add some p tags to a post I'm editing.
  • I switch to Visual, then back to HTML, and the tag and all of its content are gone.

I'm not using any extended tinymce plugin.

Any Suggestion?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Wordpress doesn't save <p> tags. Paragraphs are displayed automatically in the TinyMCE visual editor and then the output gets <p> tags automatically (for better or for worse) from the wpautop function.

I avoid using <p> tags. A double line break will automatically be converted to a paragraph at output.

share|improve this answer
    
so basically, there is not any change to avoid this behavior? –  andresmijares25 Nov 15 '12 at 17:45
    
Unfortunately not, as far as I know. Sorry that the answer is "there is no answer". You could disable the visual editor, but then you will always be obliged to work in HTML-mode. Why do you need a special <p>? Maybe there is another approach we could find. –  helgatheviking Nov 15 '12 at 21:49
    
I just didn't want to give a general line height to the body, and keep it only for paragraphs, however there is not other way. Thanks a ton for you answer. –  andresmijares25 Nov 15 '12 at 22:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.