Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

So I have deployed a WP that was local to a dev environment. I have done the following:

  • Deployed files via FTP
  • Imported DB via PHPMyAdmin
  • Modified home and siteurl values in the _options table

So far, the landing page works fine, however as soon as I try to change page, it doesn't work.

It may be interesting to say that I have deployed onto a URL like http://dev.example.com/project-name/. I cannot put it at the root, this dev servers is used to present multiple projects.

I am not at ease with databases, deployments or htaccess things, so if you must explain with these things, please be gentle with me. Any help is appreciated.

share|improve this question

2 Answers 2

You shouldn't import WordPress data via PHPMyAdmin. You should use the built-in WordPress importer/exporter, this way you will ensure that all permalinks are properly translated to your site's name. As Oleg suggested, try visiting permalink settings, this will flush the permalinks.

share|improve this answer
    
That would have saved me some time, I didn't know that existed. The thing of which I had to make sure was to change the siteurl and home vars in the _options table to that things works properly –  jansensan Nov 16 '12 at 4:08
  1. Log into wp admin
  2. Open Settings -> Permanent links
  3. Check if site links works?
  4. if NO check permitions to .htaccess in root folder. it shoudl be writable. and back to step 2.
share|improve this answer
    
There was something with the htaccess indeed, but the web host fixed that part, thanks for the guidance. –  jansensan Nov 16 '12 at 4:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.