Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I had to modify a published post and for some unknown reason, it removed the categories the post was in. I tried reassigning them, but it does not work: WordPress does not save the categories, so the post ends in the default "unclassified" category.

I've checked and it happens also if I create a new post. So it's a quite strange issue. I deactivated my caching plugin, to no avail.

Any idea what provokes this bug?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

IT turns out the Role Scoper plugin needed an update. That, and the server admin bumped a new PHP 5.3.3 update. I'm not sure which caused which exactly, but at least you know more now where to look at if the issue arises.

share|improve this answer
    
so you got it solved? Or are you still experiencing the problems? –  hakre Aug 24 '10 at 0:10

From what you describe you experience a problem that looks like a local problem on your site. Therefore the assumption is very likely that it is a configuration issue on your site and not a bug. Bug would mean this is a defect in the software. If it would be a bug, everybody using wordpress would run into this problem (or at least a great share).

Because this is not the case (for example I still can do what you describe as broken on my Blog), you need to find the problem within your blogs configuration. For example, please switch your site to the default theme and deactivate all plugins. Then test again, if you can or can not assign categories to posts.

If you still can not add categories to posts your site is very likely to be broken in configuration. Consider to contact professional wordpress support then to drill down this on your host because the reason of your problem can not be genreally found out w/o taking a look into your files and database(s).

If you can add categories after deactivating all plugins and themes, then it's highly likely that one of the Add-Ons is breaking stuff. You can now use try-and-error to find out which one of the Ad-Ons is causing this. It might be a single one (so to activate one and deactivating all others to find out) or a combination of many (so to activate group of plugins and then to test for functionality to find out).

Even these problems do occur often with third-party plugins, there is no tool or help build into wordpress that makes looking for a destructive plugin easier than doing a manual, one-by-one search.

Some trick at least is to just rename the plugin directory which temporarily prevents worpdress from loading all active plugins. Doing so makes looking for this being a plugin issue much faster than clicking through the plugin configuration in the admin.

share|improve this answer
    
thank you for this. I have tried disabling a few plugins that might be causing the problem but so far, no luck. I have heavily modified my .htaccess file. Could that be a cause? –  pixeline Aug 23 '10 at 12:22
    
@pixeline: certainly not. –  hakre Aug 24 '10 at 0:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.