Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Situation

I've just setup a new installation of WordPress (running on XAMPP/Win7). As I had a port conflict on :80/:443, I switched to :187/4430.

Error

When I'm now trying to access http://vanilla-mu.dev:187/index.php (or any other request), then I run into the following WordPress Error inside a wp_die() page:

Multisite only works without the port number in the URL.

Question

As I know that the error is non resolvable according to ticket #21077, I need to somehow change my setup. How could I work around this? What would be a setup that accounts the fact that there's a port conflict, but doesn't run into the core bug?

The setup

// ~\xampp\apache\conf\httpd.conf
Listen 187
ServerName 127.0.0.1:187

// ~\System32\drivers\etc\hosts
127.0.0.1 localhost
127.0.0.1 vanilla-mu.dev

// ~\xampp\apache\conf\extra\httpd-vhosts.conf
## vanilla-mu.dev
<VirtualHost *:187>
    ServerName www.vanilla-mu.dev
    ServerAlias vanilla-mu.dev
    DocumentRoot "C:\xampp\htdocs\vanilla-mu.dev"
    <Directory "C:\xampp\htdocs\vanilla-mu.dev">
        Options +Indexes +FollowSymLinks +Includes
        AllowOverride FileInfo
        AllowOverride All
        Order allow,deny
        Allow from all
        DirectoryIndex index.php index.shtml index.html index.htm
    </Directory>
    ErrorLog "logs/error_vanilla-mu.log"
    CustomLog "logs/access_vanilla-mu.log" combined
</VirtualHost>

EDIT: Additional info for later readers to identify possible conflicts.

Port conflict available?

First hit your Win Start Button and open the command line interface typing cmd. Then type the following line, followed by the port number to check (80 and 443).

netstat -o -n -a | findstr 0.0:80
netstat -o -n -a | findstr 0.0:443

You will then see the process(es) ID(s) that are currently using the questioned port.

enter image description here

Identify a port conflict and what is causing it

The next thing to do is to right click on your menu bar and open the Taskmanager. The Taskmanager by default doesn't show the PID. I added a screenshot that shows you how you can add it.

enter image description here

The question still remains.

share|improve this question
    
Cant you make the xamp listen on 127.0.0.2 ? –  chifliiiii Nov 9 '12 at 13:23
    
@chifliiiii Good question. Dunno, but I guess yes. What would that change for me? –  kaiser Nov 9 '12 at 14:03
1  
What domain it listens on is irrelevant if it has to listen on port 80 first –  Tom J Nowell Nov 9 '12 at 14:56
1  
I think you'll have more luck on serverfault.com - this is really straying from WP! –  TheDeadMedic Nov 9 '12 at 15:14
    
@TheDeadMedic You're absolutely right, but the problem is (as TomJNowell stated and as you can read in the trac ticket) a problem WordPress has in core. And as it isn't solved so far, I'll leave the question here. I also added the tag trac, so we can file other questions under the same ticket. I guess it will help some other people as there's close to no source available. –  kaiser Nov 9 '12 at 16:38
show 1 more comment

2 Answers

I just encountered another (non WP) problem: Skype using port 80/443. This problem will only apply if Skype starts before XAMPP (or whatever local server you're using).

To fix it go into "tools " then "options" and connection down the left, untick the box "use port 80 and 443 as alternative incomming ports".

enter image description here

share|improve this answer
add comment
up vote 0 down vote accepted

As mentioned in the question itself, this is a problem a non-solvable due to the internals of WP core.

What I did was getting rid of the interfering/colliding process - I simply turned it off (as changing the port wasn't possible).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.