Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I developed a site 6 months ago and now need to update it, but i can't access the login page to get in to it. I get a "this is somewhat embarassing" erro page. Tried wp-login.php at end of url as well but this also didn't work. Help please

share|improve this question
1  
Try to login over FTP. If you can do that you can start to work out what is wrong. –  s_ha_dum Nov 9 '12 at 1:13
    
i am in the hosts server but not sure where to try and login to wordpress here, what should i be looking for? –  reachkelly Nov 9 '12 at 1:49
    
You can't login. You can try to figure out what happened. Make sure all the files are there. Sounds like they may not be. Look around for a .htaccess file and post the contents if you find it. Also, what is your URL? –  s_ha_dum Nov 9 '12 at 2:44
    
www.childtalk.com.au is the url, i never used cpanel to login to wordpress before, am i in the right area? –  reachkelly Nov 9 '12 at 6:24
    
I have looked for the .htaccess file but can't see it, its not in any of the wp-admin, includes or content folders, not in root folder either, could this be the problem to not access the login page? –  reachkelly Nov 9 '12 at 7:50

8 Answers 8

For having trouble logging in to your WordPress Administration Panels, review this WordPress Codex: http://codex.wordpress.org/Login_Trouble

share|improve this answer

The same thing happened to me (I couldn't access 'mysite.com/wp-admin'). This happened when I installed wpcareer plug-in that requested me root access to my site. I then went to cpanel where my site is hosted and deleted that plug-in. Every thing was fine then after.

share|improve this answer
    
The same problem happened to me with "better secure plugin", the same procedure solved my problem –  Musa Nov 10 '14 at 13:16

Try disabling all your plugins by moving or deleting them from your /wp-content/plugins/ folder. Do this by FTP or by your host's control panel.

If this doesn't work, log in to the server via FTP, and upload a fresh copy of WordPress. This will fix your wp-admin, and any other folders or files that have been corrupted.

You can download a fresh copy of WordPress from WordPress.org.

For other solutions, including new login files and database-altering, see the WordPress Codex page on Login Issues.

They suggest that, in case all else fails, you post at the WordPress Support Forum. Be sure to give details of your server setup, if you know it, including mySQL and PHP versions, as well as your operating system (OS), browser, and the WordPress version that is causing these problems.

share|improve this answer

Your login screen is here: http://childtalk.com.au/wordpress/wp-login.php

You've done something like what is on this Codex page to hide the '/wordpress/' directory.

share|improve this answer

yes i also have same admin login problem, if you have wpcareers plugin and you activated it then we are facing these problems due to version support issue of wordpress , so go to your hosting area in file manager>public_html/wp-content/plugins, here public_html is my root folder of my site jobsclue.in and delete that plugin after that relogin

share|improve this answer
  • Turn on debugging log in Wp-config.php
  • Disable plugins by adding a 1 just before every plugin folder
  • Repair all tables from your MySql database (repair is a mysql feature. Repair command does not hurt)
  • Check htaccess for bad redirects
  • Check folders/files permissions (755,644)
  • In Wp-config.php => define('WP_SITEURL', 'http://example.com'); define('WP_HOME', 'http://example.com');
share|improve this answer

Please open wp-config.php file and put ob_start(); in top.

It's working for me please try this.

share|improve this answer
    
Please file an edit and explain why this would work. –  Gabriel May 8 at 9:08

I couldn't login to WP Admin either, message was "404 Page not found". I tried restoring files and database backup without success.

Then using Filezilla (you could use others), I renamed the folder /wp-content/plugins to: /wp-content/pluginsoff

I changed the permalinks (was changed by something to index.php), to the previous setting year/month/date/nameposting, and clicked Save.

I also changed the .htaccess content in root and WordPress folder with:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

I renamed all the plugin folders, such as akismet to akismetoff. After that, I renamed the folder pluginsoff back to plugins.

I checked the plugins in WP admin until there is no 404 message. Then I remove the "off" from plugin's name one by one. If you suspect a plugin is corrupt, e.g. the date is changed, it's better to delete it and reinstall it again.

Then the problem solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.