WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a multisite Wordpress installation with 2 blogs, on different domains. One of them works fine, but I just realized that for the other, I can't access the admin area. I can log in, but when accessing /wp-admin the request never returns and eventually times out. It was working fine the last time I tried (a few weeks ago), and I didn't make any changes since then...

What could be causing this? How can I get more info to help diagnose the problem? I can't find any logs on the server...

EDIT: I was using Firefox when I saw this problem; I just tried again in Chrome, which seems to have a longer timeout, and the dashboard finally appeared. The other admin pages seem to work fine, but the dashboard takes a very, very long time to load.

BTW, I'm running Wordpress 3.3.2 on IIS.

share|improve this question

For people who find this in the future: there are a ton of different causes for wp-admin timeouts. I listed as many as I could find here with their corresponding solutions:


share|improve this answer
Post your answer here, don't spam with links ;) – Krzysiek Dróżdż Jul 11 '13 at 18:24
Link is now dead. ಠ_ಠ Archived version here: web.archive.org/web/20131002051731/http://mzandstra.com/… – Nathan Craike Feb 17 '15 at 2:21
up vote 0 down vote accepted

OK, I just found the problem: I had more than 5000 spam comments (most of them from an IP range I had blacklisted). Apparently it's a problem for the dashboard, although the comments page works fine... I deleted those comments directly in the DB, and everything is back to normal. Now I just need to find a way to completely block the source IPs in IIS, otherwise I'll have the same problem in a few weeks...

share|improve this answer

So, I finally found a solution from my host. They didn't let me enter due to spamming issues. They in particular blocked the username "admin" because it was so common. An easy fix is to try changing to a different username through phpmyadmin. Otherwise ask your host. Haven't seen this solution placed anywhere else.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.