Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm trying to uplaod video files,my upload file size limit is 96mb,and I can upload videos until 10mb size,but I want to uplaod videos that have 20mb size.If I try to uplaod bigger video I get http error,I found on web a lot of solutions but none of them acctualy help me.Is there any other solution how to fix http uplaod error and uplaod bigger files on my wordpress site? I have tried every thing from there links :

http://wordpress.org/support/topic/http-error-on-image-upload-still http://wordpress.org/support/topic/flash-uploader-logs-out-during-crunching-phase http://wordpress.org/support/topic/http-error-image-upload

Tnx in advance.

Anybody have idea why is this happening ?

share|improve this question
    
Please include some details on what had you tried already, otherwise it is hard to come up with other solutions. –  Rarst Jan 17 '11 at 13:08
    
I edited my question. –  user1147 Jan 17 '11 at 13:30
    
I've seen the same problem before and I think I remember seeing someone track down a number of places that WordPress hardcodes memory limits in core. I'll see if I can find the link (might have been another question on here). –  goldenapples Jan 18 '11 at 23:27
    
If you read my answer below you might find that this is a host related issue and not a Wordpress issue at all. One way you can be sure is to write a simple file uploading PHP script and run it, then see if you get the same issues you're having in Wordpress. I'll update my answer with an example. –  DigitalSea Jan 19 '11 at 0:52
    
tnx,that will be great. –  user1147 Jan 19 '11 at 0:53
show 1 more comment

6 Answers

up vote 1 down vote accepted

Are you on shared hosting by any chance? Shared hosts tend to limit the max uploadable file size on their end and there is nothing you can add to your scripts to change that. If not, then I am mistaken and this is not the solution you are looking for.

However, if you are on shared hosting it might pay to contact them and ask them the max allowed file sizes they allow their shared hosting accounts to have. Some hosts however let you create a php.ini file, drop it into your site root directory set some hosting variables like upload limits, etc.

Try creating a file called 'php.ini' without the quotes and put in the following:

upload_max_filesize = 64M  
post_max_size = 64M

Then place the php.ini file you just created into your Wordpress root directory.

A good way to see if it is your host or Wordpress installation is to create a simple file uploading test and then try uploading the same file. If you have the same issue, it isn't Wordpress and is your server configuration.

Create a page called "file.php" and then add in the following code:

<form enctype="multipart/form-data" action="upload.php" method="POST">
    <input type="hidden" name="MAX_FILE_SIZE" value="512000" />
    Send this file: <input name="userfile" type="file" />
    <input type="submit" value="Send File" />
</form>

Now create a file called "upload.php" and add in the following:

<?php

    $uploaddir = 'uploads';
    $uploadfile = $uploaddir . basename($_FILES['userfile']['name']);

    echo "<p>";

    if (move_uploaded_file($_FILES['userfile']['tmp_name'], $uploadfile)) {
      echo "File is valid, and was successfully uploaded.\n";
    } else {
       echo "Upload failed";
    }

    echo "</p>";
    echo '<pre>';
    echo 'Here is some more debugging info:';
    print_r($_FILES);
    print "</pre>";

?>

Example code taken from here: http://snippets.dzone.com/posts/show/3729

Now see if that lets you upload a large file. If not, then we'll further try and debug your Wordpress installation to try and rectify the issue.

share|improve this answer
    
Hi,sorry for my late response,I have tried this and didn't help me.I just uploaded a file 25mb in folder –  user1147 Jan 19 '11 at 22:21
    
probably it is wp issue,for now,I will stop working on this,and use ftp for uploading files,than will later execute some sql command –  user1147 Jan 19 '11 at 22:23
    
So you're saying that the script let you upload a file without giving you any errors? –  DigitalSea Jan 19 '11 at 23:52
    
yes,I can upload without any problems,tnx for trying to help –  user1147 Jan 20 '11 at 7:17
    
Okay, so the obvious thing is that Wordpress is limiting uploads and it could be due to any of the above and below mentioned factors relating to limits. I'll look into a solution for you in a couple of hours and then post back what I find. –  DigitalSea Jan 20 '11 at 7:40
show 1 more comment

Increase the WordPress upload limit: http://wordpress.org/support/topic/how-to-increase-the-max-upload-size

share|improve this answer
    
I can set my uplaod file size,and I just setup it to 192mb,that didnt fix my problem. –  user1147 Jan 17 '11 at 21:24
add comment

if all fails try adding this lines in your functions.php

function push_the_max(){
@ini_set( 'upload_max_size' , '100M' );
@ini_set( 'post_max_size', '105M');
@ini_set( 'max_execution_time', '300' );
}
add_action('init','push_the_max');
share|improve this answer
    
it is the same thing,like changing php.ini,but I will try also this. –  user1147 Jan 17 '11 at 21:25
    
nope,it didn't help,maybe it is wordpress bug –  user1147 Jan 17 '11 at 21:49
add comment

It would be helpful to know what error message you're getting in the server logs.

But, take a look at this thread: http://wordpress.org/support/topic/how-to-increase-the-max-upload-size.

In your php.ini, add or edit the following:

upload_max_filesize = 120MB
post_max_size = 120MB

Also you may need to add this to your wp-config.php

define('WP_MEMORY_LIMIT', '120MB');

And also change your timeout values in your php.ini

max_execution_time
max_input_time

Set these to values that are larger than they are currently set to - and see what happens.

You should check these values are set correctly by checking the information returned by phpinfo()

This page seems to be a good source of all the PHP configuration settings for large file uploads: http://www.developershome.com/wap/wapUpload/wap_upload.asp?page=php2

share|improve this answer
    
I totaly forgot on wp_memory_limit,will try this,tnx –  user1147 Jan 17 '11 at 21:25
    
this didn't help –  user1147 Jan 17 '11 at 22:44
    
You're going to need to include more information: - what error are you getting in your apache logs. Where are you hosted - are you sure you have control over your own php.ini? Make a test php file and just put a call to phpinfo() into it, and see whether the changed values show up –  anu Jan 18 '11 at 8:58
    
I'm on ipage hosted,I have control over my php.ini,not sure how to get apache logs ? Can you guide me how to get apache logs? –  user1147 Jan 18 '11 at 9:30
    
check your host docs - server logs typically can be found at /var/logs/. Also, what does phpinfo() return? You might also need to edit php timeout values- I'm editing my answer with the necessary info. –  anu Jan 18 '11 at 9:52
show 7 more comments

Look at the answers given to this question:

How to use more than 256MB of memory in the admin?

Basically, there are some memory limits that are hard-coded, and one or two that are filterable. If you need to increase upload file size limits and memory limits, maybe some of those suggestions may help.

share|improve this answer
    
tnx will read post from link,and try to solve my problem.tnx –  user1147 Jan 19 '11 at 1:01
add comment

Have you tried uploading from a different computer or internet connection?

I'm having a similar problem but have found that I can upload from one location when my client is unable to upload exactly the same file from a different location. Upload media file problem

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.